summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-12-19 00:13:34 -0500
committerMatt Turner <mattst88@gentoo.org>2021-12-19 00:13:34 -0500
commit6360bace6b70f53332afcc6e5cc3685ec57f5408 (patch)
treee89d6f0cc5abafba60fbb42e2bfeeee1f7784d5a /x11-misc
parentnet-dialup/moserial: Version bump to 3.0.21 (diff)
downloadgentoo-6360bace6b70f53332afcc6e5cc3685ec57f5408.tar.gz
gentoo-6360bace6b70f53332afcc6e5cc3685ec57f5408.tar.bz2
gentoo-6360bace6b70f53332afcc6e5cc3685ec57f5408.zip
x11-misc/alacarte: Version bump to 3.42.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/alacarte/Manifest1
-rw-r--r--x11-misc/alacarte/alacarte-3.42.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/x11-misc/alacarte/Manifest b/x11-misc/alacarte/Manifest
index 2acc7ec0cda7..883e9a83e089 100644
--- a/x11-misc/alacarte/Manifest
+++ b/x11-misc/alacarte/Manifest
@@ -1 +1,2 @@
DIST alacarte-3.36.0.tar.xz 201088 BLAKE2B 26c924a8a88c014358db38496cb8a20eca82e9b3d514a9feefa64db3674527cef454346c538a1cdb04ebbb384a64dee395738d8d2a19f4d2445e887f5714f8d6 SHA512 7406fef4c59f94f26d52ad6b52ddd8a5183e9ceb50834aecd5e83f60d996ab4efd09ecbc9d3568d65fe1dd9290e446b5c5c5f6ad89c7e81b0ef304d2a10476b9
+DIST alacarte-3.42.0.tar.xz 203836 BLAKE2B e020529acd5b6b716c8e1b876b3edc1107cf61fbcebb648ce7f593e830f0ae7ea3445a5ccda2cd798e0441e999cff2e9e4630a7b2fe0b711adef56bf59931c25 SHA512 df56f79e0697268ceebd15614c9e6c6bbef82c10c64c90b39eac1718043edb1a1ea71d03798705d94407cf2dcc3fead6c2d08ff6c5a9ca710574eb15ffed68d1
diff --git a/x11-misc/alacarte/alacarte-3.42.0.ebuild b/x11-misc/alacarte/alacarte-3.42.0.ebuild
new file mode 100644
index 000000000000..6ed197189c5b
--- /dev/null
+++ b/x11-misc/alacarte/alacarte-3.42.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_REQ_USE="xml"
+
+inherit gnome2 python-single-r1
+
+DESCRIPTION="Simple GNOME menu editor"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/alacarte"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+COMMON_DEPEND="
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep 'dev-python/pygobject:3[${PYTHON_USEDEP}]')
+ >=gnome-base/gnome-menus-3.5.3:3[introspection]
+"
+RDEPEND="${COMMON_DEPEND}
+ x11-libs/gdk-pixbuf:2[introspection]
+ x11-libs/gtk+:3[introspection]
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/intltool-0.40.0
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_install() {
+ gnome2_src_install
+ python_optimize
+}