summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIngolf Wagner <contact@ingolf-wagner.de>2017-06-06 05:19:10 -0500
committerMatthias Maier <tamiko@gentoo.org>2017-06-06 05:27:09 -0500
commit6618768ee2b477120e5bbb07640fa770f4766aba (patch)
tree8956d2fa80756562ce614799004f73e2c8cc4ffc /x11-misc
parentpackage.mask: virtual/ada was only used by topal masked package (diff)
downloadgentoo-6618768ee2b477120e5bbb07640fa770f4766aba.tar.gz
gentoo-6618768ee2b477120e5bbb07640fa770f4766aba.tar.bz2
gentoo-6618768ee2b477120e5bbb07640fa770f4766aba.zip
x11-misc/slop: fixed no-opengl patch
Package-Manager: Portage-2.3.6, Repoman-2.3.2 Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/slop/files/slop-4.3.21-no-opengl.patch23
1 files changed, 22 insertions, 1 deletions
diff --git a/x11-misc/slop/files/slop-4.3.21-no-opengl.patch b/x11-misc/slop/files/slop-4.3.21-no-opengl.patch
index 7dbd45dd7d00..2f596b65e992 100644
--- a/x11-misc/slop/files/slop-4.3.21-no-opengl.patch
+++ b/x11-misc/slop/files/slop-4.3.21-no-opengl.patch
@@ -1,7 +1,8 @@
diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 62cc1a6..f5d66e5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
-@@ -67,14 +67,8 @@ endif()
+@@ -71,14 +71,8 @@ endif()
# Obtain library paths and make sure they exist.
set( CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} "${CMAKE_SOURCE_DIR}/cmakemodules" )
@@ -16,3 +17,23 @@ diff --git a/CMakeLists.txt b/CMakeLists.txt
set( CMAKE_CXX_FLAGS
"${CMAKE_CXX_FLAGS} ${CMAKE_IMLIB2_CXX_FLAGS}" )
+diff --git a/src/x.hpp b/src/x.hpp
+index 2478414..f35e722 100644
+--- a/src/x.hpp
++++ b/src/x.hpp
+@@ -26,7 +26,6 @@
+ #include <X11/Xlib.h>
+ #include <X11/cursorfont.h>
+ #include <X11/extensions/shape.h>
+-#include <X11/extensions/Xrandr.h>
+
+ #include <stdlib.h>
+ #include <cstring>
+@@ -97,7 +96,6 @@ public:
+ std::vector<bool> m_mouse;
+ bool mouseDown( unsigned int button );
+ bool m_keypressed;
+- XRRScreenResources* m_res;
+ private:
+ slop::CursorType m_currentCursor;
+ bool m_good;