summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conrad@kostecki.com>2019-09-17 20:55:53 +0200
committerJoonas Niilola <juippis@gentoo.org>2019-09-18 06:33:35 +0300
commit729f378babf59b1b8d6612a24aaff6e194ee0f6e (patch)
tree66aec678c6055a43dfd8766904602e6623b95743 /x11-misc
parentapp-pda/usbmuxd: version bump to 1.1.0 (diff)
downloadgentoo-729f378babf59b1b8d6612a24aaff6e194ee0f6e.tar.gz
gentoo-729f378babf59b1b8d6612a24aaff6e194ee0f6e.tar.bz2
gentoo-729f378babf59b1b8d6612a24aaff6e194ee0f6e.zip
x11-misc/xflux-gui: disable gschemas compilation
Since Gentoo uses its own method for compiling gschemas, disabling this for that package, as otherwise it causes a file collision. Reported to upstream (patch got merged already): https://www.github.com/xflux-gui/fluxgui/issues/124 Closes: https://bugs.gentoo.org/691950 Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Conrad Kostecki <conrad@kostecki.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/xflux-gui/files/xflux-gui-1.2.0-disable-gschemas-compiled.patch37
-rw-r--r--x11-misc/xflux-gui/xflux-gui-1.2.0-r1.ebuild48
2 files changed, 85 insertions, 0 deletions
diff --git a/x11-misc/xflux-gui/files/xflux-gui-1.2.0-disable-gschemas-compiled.patch b/x11-misc/xflux-gui/files/xflux-gui-1.2.0-disable-gschemas-compiled.patch
new file mode 100644
index 000000000000..dc14be17339b
--- /dev/null
+++ b/x11-misc/xflux-gui/files/xflux-gui-1.2.0-disable-gschemas-compiled.patch
@@ -0,0 +1,37 @@
+From 674d17b100f7b8a471d65b61749ca892567f8d58 Mon Sep 17 00:00:00 2001
+From: Conrad Kostecki <conrad@kostecki.com>
+Date: Fri, 16 Aug 2019 16:02:59 +0200
+Subject: [PATCH] setup.py: add posbility to disable compilation of gschema
+
+When you install fluxgui, it also compiles the gschema, which is for
+most distros fine. But on source distros like Gentoo, which do the
+compilation of gschema separately, this will lead to a file collision,
+as packages unter Gentoo are not allowed to install such files.
+
+So we introduce a new env variable called DISABLE_GSCHEMA_COMPILED which
+needs to be set to disable this behaviour.
+
+Closes: https://github.com/xflux-gui/fluxgui/issues/124
+Signed-off-by: Conrad Kostecki <conrad@kostecki.com>
+---
+ setup.py | 7 ++++---
+ 1 file changed, 4 insertions(+), 3 deletions(-)
+
+diff --git a/setup.py b/setup.py
+index 8a8fa14..4bd404d 100755
+--- a/setup.py
++++ b/setup.py
+@@ -76,9 +76,10 @@ def run(self):
+ super().run()
+
+ # Compile '*.gschema.xml' to update or create 'gschemas.compiled'.
+- info("compiling gsettings schemas")
+- gschema_dir = os.path.join(self.install_dir, gschema_dir_suffix)
+- self.spawn(["glib-compile-schemas", gschema_dir])
++ if os.environ.get('DISABLE_GSCHEMAS_COMPILED', None) is None:
++ info("compiling gsettings schemas")
++ gschema_dir = os.path.join(self.install_dir, gschema_dir_suffix)
++ self.spawn(["glib-compile-schemas", gschema_dir])
+
+ setup(name = "f.lux indicator applet",
+ version = "1.2.1~pre",
diff --git a/x11-misc/xflux-gui/xflux-gui-1.2.0-r1.ebuild b/x11-misc/xflux-gui/xflux-gui-1.2.0-r1.ebuild
new file mode 100644
index 000000000000..1eaaa8fe5745
--- /dev/null
+++ b/x11-misc/xflux-gui/xflux-gui-1.2.0-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+
+inherit distutils-r1 gnome2-utils xdg-utils
+
+DESCRIPTION="A GUI for f.lux"
+HOMEPAGE="https://justgetflux.com/"
+SRC_URI="https://github.com/${PN}/fluxgui/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+
+PATCHES=( "${FILESDIR}/${P}-disable-gschemas-compiled.patch" )
+
+RDEPEND="
+ dev-libs/libappindicator:3
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pygobject[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ x11-libs/libXxf86vm
+ x11-misc/xflux
+"
+
+S="${WORKDIR}/fluxgui-${PV}"
+
+python_install() {
+ # Don't let the package compiling the schemas, as this could cause a file collision
+ export DISABLE_GSCHEMAS_COMPILED="true"
+
+ distutils-r1_python_install
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}