summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-12-27 10:45:11 +0000
committerSam James <sam@gentoo.org>2022-12-27 10:45:11 +0000
commit74922f6671fadafab953e6d552a81a070a9f103e (patch)
treef0d8df06ac258892a7023478b20f7bc8bc03822e /x11-misc
parentx11-misc/rofi: add flex version requirement (diff)
downloadgentoo-74922f6671fadafab953e6d552a81a070a9f103e.tar.gz
gentoo-74922f6671fadafab953e6d552a81a070a9f103e.tar.bz2
gentoo-74922f6671fadafab953e6d552a81a070a9f103e.zip
x11-misc/rofi: force flex, not reflex
Bug: https://bugs.gentoo.org/887049 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/rofi/rofi-1.6.1-r1.ebuild3
-rw-r--r--x11-misc/rofi/rofi-1.7.3-r1.ebuild3
-rw-r--r--x11-misc/rofi/rofi-1.7.5.ebuild3
-rw-r--r--x11-misc/rofi/rofi-99999.ebuild5
4 files changed, 13 insertions, 1 deletions
diff --git a/x11-misc/rofi/rofi-1.6.1-r1.ebuild b/x11-misc/rofi/rofi-1.6.1-r1.ebuild
index 664fa0b6b465..066a6e8fcacd 100644
--- a/x11-misc/rofi/rofi-1.6.1-r1.ebuild
+++ b/x11-misc/rofi/rofi-1.6.1-r1.ebuild
@@ -51,6 +51,9 @@ src_prepare() {
}
src_configure() {
+ # Doesn't work with reflex, bug #887049
+ export LEX=flex
+
tc-export CC
local myeconfargs=(
diff --git a/x11-misc/rofi/rofi-1.7.3-r1.ebuild b/x11-misc/rofi/rofi-1.7.3-r1.ebuild
index d88c80ce18f7..803fb05e4226 100644
--- a/x11-misc/rofi/rofi-1.7.3-r1.ebuild
+++ b/x11-misc/rofi/rofi-1.7.3-r1.ebuild
@@ -45,6 +45,9 @@ src_prepare() {
}
src_configure() {
+ # Doesn't work with reflex, bug #887049
+ export LEX=flex
+
tc-export CC
local myeconfargs=(
diff --git a/x11-misc/rofi/rofi-1.7.5.ebuild b/x11-misc/rofi/rofi-1.7.5.ebuild
index 4125a5c5a387..c51049b5e10e 100644
--- a/x11-misc/rofi/rofi-1.7.5.ebuild
+++ b/x11-misc/rofi/rofi-1.7.5.ebuild
@@ -45,6 +45,9 @@ src_prepare() {
}
src_configure() {
+ # Doesn't work with reflex, bug #887049
+ export LEX=flex
+
tc-export CC
local myeconfargs=(
diff --git a/x11-misc/rofi/rofi-99999.ebuild b/x11-misc/rofi/rofi-99999.ebuild
index 66b4e07790bd..e790ecc3ac90 100644
--- a/x11-misc/rofi/rofi-99999.ebuild
+++ b/x11-misc/rofi/rofi-99999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -49,6 +49,9 @@ src_prepare() {
}
src_configure() {
+ # Doesn't work with reflex, bug #887049
+ export LEX=flex
+
tc-export CC
local myeconfargs=(