summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2021-01-04 22:48:18 +0100
committerLars Wendler <polynomial-c@gentoo.org>2021-01-04 22:48:37 +0100
commit7e47fbe82f079526433889b021aded8d6c1e57a2 (patch)
tree835a50e2004a1306b91726d0ceb92ecd8856d4ac /x11-misc
parentdev-libs/rocksdb-6.15.2: Version bump (diff)
downloadgentoo-7e47fbe82f079526433889b021aded8d6c1e57a2.tar.gz
gentoo-7e47fbe82f079526433889b021aded8d6c1e57a2.tar.bz2
gentoo-7e47fbe82f079526433889b021aded8d6c1e57a2.zip
x11-misc/rofi: Fixed build with ~sys-devel/autoconf-2.70
Closes: https://bugs.gentoo.org/749864 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/rofi/files/rofi-1.6.1-autoconf-2.70.patch30
-rw-r--r--x11-misc/rofi/rofi-1.6.1.ebuild12
2 files changed, 37 insertions, 5 deletions
diff --git a/x11-misc/rofi/files/rofi-1.6.1-autoconf-2.70.patch b/x11-misc/rofi/files/rofi-1.6.1-autoconf-2.70.patch
new file mode 100644
index 000000000000..d2ac9510d3cb
--- /dev/null
+++ b/x11-misc/rofi/files/rofi-1.6.1-autoconf-2.70.patch
@@ -0,0 +1,30 @@
+From 7e426c597539c1b6f33c34300b84d2074f94c9b6 Mon Sep 17 00:00:00 2001
+From: Lars Wendler <polynomial-c@gentoo.org>
+Date: Mon, 4 Jan 2021 22:27:37 +0100
+Subject: [PATCH] configure.ac: Remove argument from AC_PROG_LEX
+
+autoconf-2.70 only accepts "yywrap" and "noyywrap" as arguments to
+AC_PROG_LEX. Calling it with no arguments will trigger the old behavior
+from autoconf-2.69.
+
+Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
+---
+ configure.ac | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index e0968b65..03dc1d2f 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -7,7 +7,7 @@ AH_BOTTOM([#include "gitconfig.h"])
+ dnl ---------------------------------------------------------------------
+ dnl Lex & Bison language parser.
+ dnl ---------------------------------------------------------------------
+-AC_PROG_LEX([flex])
++AC_PROG_LEX
+ AC_PROG_YACC
+
+
+--
+2.30.0
+
diff --git a/x11-misc/rofi/rofi-1.6.1.ebuild b/x11-misc/rofi/rofi-1.6.1.ebuild
index 44eda2ab0a9a..297c2f078d6b 100644
--- a/x11-misc/rofi/rofi-1.6.1.ebuild
+++ b/x11-misc/rofi/rofi-1.6.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -41,19 +41,21 @@ DEPEND="
PATCHES=(
"${FILESDIR}"/${PN}-0.15.12-Werror.patch
"${FILESDIR}"/${PN}-1.5.0-gtk-settings-test.patch
+ "${FILESDIR}"/${PN}-1.6.1-autoconf-2.70.patch
)
src_prepare() {
default
-
eautoreconf
}
src_configure() {
tc-export CC
- econf \
- $(use_enable drun) \
- $(use_enable test check) \
+ local myeconfargs=(
+ $(use_enable drun)
+ $(use_enable test check)
$(use_enable windowmode)
+ )
+ econf "${myeconfargs[@]}"
}