summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVladimir Pavljuchenkov (SpiderX) <spiderx@spiderx.dp.ua>2021-01-15 20:46:55 +0200
committerJoonas Niilola <juippis@gentoo.org>2021-01-16 10:03:00 +0200
commit826a84fac54a69deb96191ad93eb4bd03d19d66c (patch)
tree2d37948f8eb1e66b7a6d9c883b5413a37a333dfd /x11-misc
parentapp-misc/rpick: Drop 0.6.1 (diff)
downloadgentoo-826a84fac54a69deb96191ad93eb4bd03d19d66c.tar.gz
gentoo-826a84fac54a69deb96191ad93eb4bd03d19d66c.tar.bz2
gentoo-826a84fac54a69deb96191ad93eb4bd03d19d66c.zip
x11-misc/libinput-gestures: version bump, move to xdg eclass
Closes: https://bugs.gentoo.org/753227 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Vladimir Pavljuchenkov <spiderx@spiderx.dp.ua> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/libinput-gestures/Manifest1
-rw-r--r--x11-misc/libinput-gestures/libinput-gestures-2.56.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/x11-misc/libinput-gestures/Manifest b/x11-misc/libinput-gestures/Manifest
index 844d864cb122..983b5ebd910c 100644
--- a/x11-misc/libinput-gestures/Manifest
+++ b/x11-misc/libinput-gestures/Manifest
@@ -1 +1,2 @@
DIST libinput-gestures-2.48.tar.gz 22858 BLAKE2B 67fada253a0d02791e14c6c2175f37f75c2e4ff04b04360070d1c045cf064a9d7b362c28a1e8130e6cc435bd487370c69ded3af41d53b935f7024d722aca9593 SHA512 6ad510f2067ab6cef9c9a94f1c300fe91aa811904a0e85209dc06b3afdd4a2be8ae7bda8ccb40210cc59c3758e3b14b53285f7c3c29c6982a3894952b678a840
+DIST libinput-gestures-2.56.tar.gz 26293 BLAKE2B b48a33c13efc63545bcb5ae722066493bd6aba083a07b1ebbf10eea69afa2a8f9d80a92b60dda3e8472a55851b70e84cf7c10e0bf3428c2278dd3ef5b6f65d0d SHA512 f215444dbe7e70ae137404beb25d5a60c5a618fb2d3d20eb9b4cf3f94cbc93a7e42a5fa82efdea082e2fa229c95d86c02df91c59f4a51c067e47ccf5dcf79fa7
diff --git a/x11-misc/libinput-gestures/libinput-gestures-2.56.ebuild b/x11-misc/libinput-gestures/libinput-gestures-2.56.ebuild
new file mode 100644
index 000000000000..ef3844015c8f
--- /dev/null
+++ b/x11-misc/libinput-gestures/libinput-gestures-2.56.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit python-single-r1 xdg
+
+DESCRIPTION="Actions gestures on your touchpad using libinput"
+HOMEPAGE="https://github.com/bulletmark/libinput-gestures"
+if [[ ${PV} == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/bulletmark/${PN}.git"
+else
+ SRC_URI="https://github.com/bulletmark/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-libs/libinput
+ x11-misc/wmctrl
+ x11-misc/xdotool"
+DEPEND="dev-libs/libinput
+ dev-util/desktop-file-utils"
+
+src_prepare() {
+ default
+
+ # Fix docdir installation path
+ sed -i "/^DOCDIR/s@\$NAME@${PF}@" libinput-gestures-setup \
+ || die "sed failed for libinput-gestures-setup"
+}
+
+src_test() { :; }
+
+pkg_postinst() {
+ xdg_icon_cache_update
+
+ elog "You must be in the input group to read the touchpad device."
+
+ if ! has_version x11-libs/gtk+:3 ; then
+ elog "${PN}-setup script supports Gnome 3 via x11-libs/gtk+:3."
+ fi
+ if ! has_version kde-plasma/kde-cli-tools:5 ; then
+ elog "${PN}-setup script supports Plasma 5 via kde-plasma/kde-cli-tools:5."
+ fi
+}