summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-09-04 10:31:19 +0200
committerJeroen Roovers <jer@gentoo.org>2020-09-04 10:33:23 +0200
commit8af55093fbb01ec76f9f05fddcbefb3c6536905d (patch)
tree6dceff93de30f64ef13b16bd5662eb009d99eadb /x11-misc
parentx11-misc/dunst: Version 1.5.0 (diff)
downloadgentoo-8af55093fbb01ec76f9f05fddcbefb3c6536905d.tar.gz
gentoo-8af55093fbb01ec76f9f05fddcbefb3c6536905d.tar.bz2
gentoo-8af55093fbb01ec76f9f05fddcbefb3c6536905d.zip
x11-misc/xautolock: Version 2.2_p7
Package-Manager: Portage-3.0.5, Repoman-3.0.1 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/xautolock/Manifest1
-rw-r--r--x11-misc/xautolock/xautolock-2.2_p7.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/x11-misc/xautolock/Manifest b/x11-misc/xautolock/Manifest
index bda938b77423..90006c192c31 100644
--- a/x11-misc/xautolock/Manifest
+++ b/x11-misc/xautolock/Manifest
@@ -2,3 +2,4 @@ DIST xautolock-2.2.tgz 35288 BLAKE2B 0cd709470002d7a6852a41a56e9f6b540405e172f30
DIST xautolock_2.2-5.1.debian.tar.xz 5828 BLAKE2B 6a664d30b993986e70af853c037738da0576ca5ee3a0452329d4dffd3132899d1099b5bcc5bbf68ab688240b388396335b0d5227b140a74deca313112d0088cd SHA512 315f27518b89fa6633e3ce157423cd271f3db3b797fc59febc35aa8b33379bd6eda55ac9c7ccdf996c2d9d50bb6bef3b15add84b39236ace425740238de77e59
DIST xautolock_2.2-5.2.debian.tar.xz 6216 BLAKE2B bda8c7a084e8975d268d626cc5aa02c87c7e6b0ae92351375f298cde4fabd8e48a0578c7c4bf32a280e2ecf13d82b7dcd73a874863616c0f9812ea98ffbe27e8 SHA512 807c9c7da51b16ed3a6600732f8d3b606d2f6c628238df0e6d975ea176ddce3d0e321779b19662f693ed1811b288ddae1b45228c0939e0728c122c1a2e556391
DIST xautolock_2.2-6.debian.tar.xz 6376 BLAKE2B a7ef40b0fedd21146e359b85b7245695d9395a54aac568800b80a89fb13a08616fe771997d8b9e155c49f8218447022fcb2b256802156ee5f66d923e394a53ba SHA512 c5d350ae2e123e63564e9145de3a7a180b47cca745262cc4f935ced83e0fe2450d68fcbd0c3de3f4566e6650b3d6183b4491f5a2d0caed838221d2bc0b9e1613
+DIST xautolock_2.2-7.debian.tar.xz 7976 BLAKE2B d56687d0eee58e513eae152f2d6d30496346935a05410759eb116eb9fb19c3073db10f1393ab26ae5a63436693b82557b01c0dc18be75af4ee04de8a783bc618 SHA512 5cc0cce408466a57fc99d701199b6a1b3545d9faae86e2474450263a07fbe9920dc89cc3ac14bd8a00274e7e80768be3e360e81ad7378bcdbe34ada23958745a
diff --git a/x11-misc/xautolock/xautolock-2.2_p7.ebuild b/x11-misc/xautolock/xautolock-2.2_p7.ebuild
new file mode 100644
index 000000000000..1abba4868157
--- /dev/null
+++ b/x11-misc/xautolock/xautolock-2.2_p7.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DESCRIPTION="An automatic X screen-locker/screen-saver"
+HOMEPAGE="http://www.ibiblio.org/pub/Linux/X11/screensavers/"
+
+DEB_REVISION="$(ver_cut 4)"
+SRC_URI="
+ http://www.ibiblio.org/pub/Linux/X11/screensavers/${P/_p*/}.tgz
+ mirror://debian/pool/main/x/${PN}/${PN}_${PV/_p*/}-${DEB_REVISION}.debian.tar.xz
+"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~sparc ~x86"
+
+RDEPEND="
+ x11-libs/libXScrnSaver
+"
+DEPEND="
+ ${RDEPEND}
+ app-text/rman
+ x11-base/xorg-proto
+ x11-misc/imake
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.2_p5_p1-waitpid.patch
+)
+S=${WORKDIR}/${P/_p*}
+
+src_prepare() {
+ mv "${WORKDIR}"/debian/patches/14-do-not-use-union-wait-type.patch{,.skip} || die
+ eapply "${WORKDIR}"/debian/patches/*.patch
+ default
+}
+
+src_configure() {
+ xmkmf || die
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ CDEBUGFLAGS="${CFLAGS}" \
+ EXTRA_LDOPTIONS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin xautolock
+ newman xautolock.man xautolock.1
+ dodoc Changelog Readme Todo
+}