summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-02-02 20:37:17 +0100
committerJeroen Roovers <jer@gentoo.org>2020-02-02 20:37:54 +0100
commit92c79f9b3ca51af2f91c4ac55dadcf757040f67e (patch)
treef0aece9447167191f1dff04daef9d7e40300791b /x11-misc
parentx11-misc/xdotool: Old (diff)
downloadgentoo-92c79f9b3ca51af2f91c4ac55dadcf757040f67e.tar.gz
gentoo-92c79f9b3ca51af2f91c4ac55dadcf757040f67e.tar.bz2
gentoo-92c79f9b3ca51af2f91c4ac55dadcf757040f67e.zip
x11-misc/xlockmore: Version 5.62_alpha0
Package-Manager: Portage-2.3.87, Repoman-2.3.20 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/xlockmore/Manifest1
-rw-r--r--x11-misc/xlockmore/xlockmore-5.62_alpha0.ebuild109
2 files changed, 110 insertions, 0 deletions
diff --git a/x11-misc/xlockmore/Manifest b/x11-misc/xlockmore/Manifest
index 6e41fd016377..93fd14a3bd0d 100644
--- a/x11-misc/xlockmore/Manifest
+++ b/x11-misc/xlockmore/Manifest
@@ -1,3 +1,4 @@
DIST xlockmore-5.50.tar.xz 1632968 BLAKE2B 2e692d16d70e3186ec1f31c192414b286f8815f2f428a6f7f43b3de0117c51c4ad2fbdfb91debe2ecb75c8683212b5d33bee62d81374552703d578b02d3af036 SHA512 627a905c4641d6083676a766931f23c06e2ac5af9b43447ccf03143d329d24b786aac6b248318929399b5fae98f1ec17e676466b5cbd09f180377c483694c569
DIST xlockmore-5.59.tar.xz 1935296 BLAKE2B 3a7027dad227179dfe3917108f8960a751cc16481fef541e80c656f99832de6d203cad1815f0f31f66aa2338d06035a99dce18664af2bc0b8e4610ef25339d20 SHA512 02758869ba597ef32ed1e594fa88141644264bbbc8edfe9ae8742a4508fa3e38d059c9ffbb9fa9bcc323b92e1763f96c8b6d054494849df465a08bc6be71bf33
DIST xlockmore-5.61.tar.xz 1936312 BLAKE2B f4d12f1dbd5da1d8cef16690e393fdd9ba4162722398c8239c0091f2cd46cc3f401c1a62ed1910bf37fc0d98f0bf0723ca9003caf507e3d8a6a83f7b51228f35 SHA512 be64b3dc22f1c0c310ed4a085fcaf9f7ed96c5d2a97f3359966201df54fc5acfc3e5d94cb0616a28a217e0cc6954f9a519198c238e40202263a7c03438771a7d
+DIST xlockmore-5.62ALPHA0.tar.xz 1942228 BLAKE2B 3b40c3d7c29a4e285dca7b6ade8555f0946872c65920be691cff859558abd825709d5adf9b9abc95bede94a6905845910562552734817711a8e3d1dc99bb2f7e SHA512 095a5d9e382ea61f77d5888fe2e38b216991e47cbe9e9739a4ccd06a8e7992284bd2ec85d73ea3a1ed07e57e3fa29938732f813360db2d146efa9e21fecac7d0
diff --git a/x11-misc/xlockmore/xlockmore-5.62_alpha0.ebuild b/x11-misc/xlockmore/xlockmore-5.62_alpha0.ebuild
new file mode 100644
index 000000000000..b993e74bcdd2
--- /dev/null
+++ b/x11-misc/xlockmore/xlockmore-5.62_alpha0.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools flag-o-matic pam
+
+DESCRIPTION="Just another screensaver application for X"
+HOMEPAGE="https://www.sillycycle.com/xlockmore.html"
+SRC_URI="
+ https://www.sillycycle.com/xlock/${P/_alpha/ALPHA}.tar.xz
+"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="crypt debug gtk imagemagick motif nas opengl pam truetype xinerama xlockrc vtlock"
+
+REQUIRED_USE="
+ || ( crypt pam )
+ pam? ( !xlockrc )
+ xlockrc? ( !pam )
+"
+RDEPEND="
+ gtk? ( x11-libs/gtk+:2 )
+ imagemagick? ( media-gfx/imagemagick:= )
+ motif? ( >=x11-libs/motif-2.3:0 )
+ nas? ( media-libs/nas )
+ opengl? (
+ virtual/opengl
+ virtual/glu
+ truetype? ( >=media-libs/ftgl-2.1.3_rc5 )
+ )
+ pam? ( sys-libs/pam )
+ truetype? ( media-libs/freetype:2 )
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXmu
+ x11-libs/libXpm
+ x11-libs/libXt
+ xinerama? ( x11-libs/libXinerama )
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+ x11-base/xorg-proto
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-5.46-freetype261.patch
+ "${FILESDIR}"/${PN}-5.47-CXX.patch
+ "${FILESDIR}"/${PN}-5.47-strip.patch
+)
+S=${WORKDIR}/${P/_alpha/ALPHA}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=()
+
+ if use opengl && use truetype; then
+ myconf=( --with-ftgl )
+ append-cppflags -DFTGL213
+ else
+ myconf=( --without-ftgl )
+ fi
+
+ myconf+=(
+ $(use_enable pam)
+ $(use_enable xlockrc)
+ $(use_enable vtlock)
+ $(use_with crypt)
+ $(use_with debug editres)
+ $(use_with gtk gtk2)
+ $(use_with imagemagick magick)
+ $(use_with motif)
+ $(use_with nas)
+ $(use_with opengl mesa)
+ $(use_with opengl)
+ $(use_with truetype freetype)
+ $(use_with truetype ttf)
+ $(use_with xinerama)
+ --disable-mb
+ --enable-appdefaultdir=/usr/share/X11/app-defaults
+ --enable-syslog
+ --enable-vtlock
+ --without-esound
+ --without-gtk
+ )
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ local DOCS=( README docs/{3d.howto,cell_automata,HACKERS.GUIDE,Purify,Revisions,TODO} )
+ default
+
+ pamd_mimic_system xlock auth
+
+ if use pam; then
+ fperms 755 /usr/bin/xlock
+ else
+ fperms 4755 /usr/bin/xlock
+ fi
+
+ docinto html
+ dodoc docs/xlock.html
+}