summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmy Liffey <amynka@gentoo.org>2019-11-07 19:59:16 +0100
committerAmy Liffey <amynka@gentoo.org>2019-11-07 20:00:12 +0100
commita1808739511245240a6ac3344ca2b43548db4879 (patch)
tree8efa5db5111c80b15370325450a52f562f5338f9 /x11-misc
parentapp-vim/vim-tmux: arm64 stable (bug #695252) (diff)
downloadgentoo-a1808739511245240a6ac3344ca2b43548db4879.tar.gz
gentoo-a1808739511245240a6ac3344ca2b43548db4879.tar.bz2
gentoo-a1808739511245240a6ac3344ca2b43548db4879.zip
x11-misc/tint2: version bump 16.7
Closes: https://bugs.gentoo.org/699542 Submitted-by: Aaron W. Swenson <titanofold@gentoo.org> Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Amy Liffey <amynka@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/tint2/Manifest1
-rw-r--r--x11-misc/tint2/tint2-16.7.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/x11-misc/tint2/Manifest b/x11-misc/tint2/Manifest
index ae9affc21a60..092682d2c565 100644
--- a/x11-misc/tint2/Manifest
+++ b/x11-misc/tint2/Manifest
@@ -1,3 +1,4 @@
DIST tint2-16.2.tar.gz 537236 BLAKE2B b8ff236f4c21465603c3cdf1e3d9f62e238cfbd05fbb7976e4f90ac054566eb433d8be78ee657421b94465dceeb8461ace202090b08585693f13003d401e4faf SHA512 0e267d59aef3d812ab41c1e5904e3e96162afd8d98c76dc697fe8c2815707f34a31e392f68260311bdc66fcb4c0b1766ad549ff30d4314e6ab2e2debf069cafe
DIST tint2-16.6.1.tar.gz 546590 BLAKE2B 0e970293b09ba766d795b7bc454f06c7a9e95a7c3534144583f5739fd275d3fee2568677f24b5d9b0809ebbc466351cfa17f91dbb726f5cdae3a0bdc9b9df16f SHA512 ae3b8c7b1573f7bb993a587a125341e4018ace605b4b357a7d633beb02e7622443b92cd11b95028d4704e94211ae9f2e13e89cd3bca91474e7daba2fb9fc2b46
DIST tint2-16.6.tar.gz 546960 BLAKE2B 083e29d754c1faa9eff50dc480d18df99d64f44a2f88673f06e659d55de13c074eacf4614a57211d5b5aeec3a10f3d68471212d24a7280020b52fe91777d305d SHA512 f81770f330d3f2462292f726a6a90ac0182c518b2db7d79f098babe52863e5ceaf4293f975708f83fbc26735c79fdfefd110102ef0f4be45ae242b4f664d72b1
+DIST tint2-16.7.tar.gz 551525 BLAKE2B 890018f219cac86dcfdacb292799ef83a4f039a6c617bd719d57eed317eb5882889e5241283aeccccd3eb174f3d20a5d2468c138f613ad62503a9d365a54c59f SHA512 7f0a7bf8514d698df078fbc4103f82ba926aba3eeef709cace35de1a5f5dce0ac00eede7445e62ac19ef7b84da9fbe7dd61c65f3fc4436bf34997bdee511c5c3
diff --git a/x11-misc/tint2/tint2-16.7.ebuild b/x11-misc/tint2/tint2-16.7.ebuild
new file mode 100644
index 000000000000..40278f4826fa
--- /dev/null
+++ b/x11-misc/tint2/tint2-16.7.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils vcs-snapshot xdg
+
+DESCRIPTION="tint2 is a lightweight panel/taskbar for Linux."
+HOMEPAGE="https://gitlab.com/o9000/tint2"
+SRC_URI="https://gitlab.com/o9000/${PN}/repository/archive.tar.gz?ref=v${PV} -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="battery svg startup-notification tint2conf"
+
+DEPEND="
+ dev-libs/glib:2
+ svg? ( gnome-base/librsvg:2 )
+ >=media-libs/imlib2-1.4.2[X,png]
+ x11-libs/cairo[X]
+ x11-libs/pango
+ tint2conf? ( x11-libs/gtk+:2 )
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXinerama
+ >=x11-libs/libXrandr-1.3
+ x11-libs/libXrender
+ startup-notification? ( x11-libs/startup-notification )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ xdg_src_prepare
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -Ddocdir="${EPREFIX}/usr/share/doc/${PF}"
+ -DENABLE_BATTERY="$(usex battery)"
+ -DENABLE_TINT2CONF="$(usex tint2conf)"
+ -DENABLE_SN="$(usex startup-notification)"
+ -DENABLE_RSVG="$(usex svg)"
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+}
+
+pkg_preinst() {
+ xdg_pkg_preinst
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+}