summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarty E. Plummer <hanetzer@startmail.com>2018-07-27 18:39:53 -0500
committerMatt Turner <mattst88@gentoo.org>2018-07-27 17:38:27 -0700
commita44f3dfd4312c50e546a5dfbedd2702df1557d94 (patch)
tree628af9b6d48b25837c485ec3c02b50e739c2d066 /x11-misc
parentx11-misc/lndir: add live ebuild (diff)
downloadgentoo-a44f3dfd4312c50e546a5dfbedd2702df1557d94.tar.gz
gentoo-a44f3dfd4312c50e546a5dfbedd2702df1557d94.tar.bz2
gentoo-a44f3dfd4312c50e546a5dfbedd2702df1557d94.zip
x11-misc/makedepend: port to EAPI 7
Package-Manager: Portage-2.3.41, Repoman-2.3.9
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/makedepend/makedepend-1.0.5-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/x11-misc/makedepend/makedepend-1.0.5-r1.ebuild b/x11-misc/makedepend/makedepend-1.0.5-r1.ebuild
new file mode 100644
index 000000000000..ee323d6f29a0
--- /dev/null
+++ b/x11-misc/makedepend/makedepend-1.0.5-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="create dependencies in makefiles"
+HOMEPAGE="https://www.x.org/wiki/ https://cgit.freedesktop.org/"
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://anongit.freedesktop.org/git/xorg/util/makedepend.git"
+ inherit autotools git-r3
+ # x11-misc-util/macros only required on live ebuilds
+ LIVE_DEPEND=">=x11-misc/util-macros-1.18"
+else
+ SRC_URI="mirror://xorg/util/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+BDEPEND="
+ virtual/pkgconfig
+"
+RDEPEND=""
+DEPEND="
+ ${LIVE_DEPEND}
+ ${RDEPEND}
+ x11-base/xorg-proto
+"
+
+src_prepare() {
+ default
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ local econfargs=(
+ --disable-selective-werror
+ )
+
+ econf "${econfargs[@]}"
+}