summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Helmert III <jchelmert3@posteo.net>2020-12-08 01:23:41 -0600
committerSam James <sam@gentoo.org>2020-12-15 03:48:48 +0000
commitadfc41da60b12450cf75b4d31004d98481e55225 (patch)
treee09f27c32ce13aec82e5bcccf3e8e92037d082bb /x11-misc
parentmedia-fonts/cascadia-code: minor style changes (diff)
downloadgentoo-adfc41da60b12450cf75b4d31004d98481e55225.tar.gz
gentoo-adfc41da60b12450cf75b4d31004d98481e55225.tar.bz2
gentoo-adfc41da60b12450cf75b4d31004d98481e55225.zip
x11-misc/rofi: bump to 1.6.1
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: John Helmert III <jchelmert3@posteo.net> Closes: https://github.com/gentoo/gentoo/pull/18561 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/rofi/Manifest1
-rw-r--r--x11-misc/rofi/rofi-1.6.1.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/x11-misc/rofi/Manifest b/x11-misc/rofi/Manifest
index f2d32aab71ae..419e55af09c0 100644
--- a/x11-misc/rofi/Manifest
+++ b/x11-misc/rofi/Manifest
@@ -1,2 +1,3 @@
DIST rofi-1.5.4.tar.gz 535259 BLAKE2B 8560dfee631c66a6f2178c0af6926ef317ed6d2cfe3ae46264e5b1ce429113ce810e4fed4c86a81acbbd51c85ad2593f40a39d982d7da0aa8ccc55537cadd2bb SHA512 181dedb0905bfab76f7ad313d299f4c80ee4efb11a2c6345b16044b7fb3f54bc7e304ee9352e562932e55108e328e5f6bd2c1d7fd9bcdec3d8022c2dc4f8d394
DIST rofi-1.6.0.tar.gz 558808 BLAKE2B 45849f71becd3ab69b85dae64af34ad42199c20976304b89b013405f1d7fbbfa8fdf7d3ac4c26563cc2f5924fad64d45da1ba7dcad8857fb127eaf4b40c08824 SHA512 a993b0d49681eae4bc4aa84277f6daf1467e53bc40fa43e97ccf3f834763a3c9a1ed8b5d1d628158febc9e8b339be3fb745ae5b4e1d86e9f84b7af4b6a30ea23
+DIST rofi-1.6.1.tar.gz 569262 BLAKE2B 938b45f8326b5a28e349ac9f7028c476274faa4f932a773acc350d5e1dc8d5c05c7cfb7ec10f1ab5d8c83590074424c3379768671d37ee799d78e508b8c4a4cb SHA512 b54e75818a98fa9262a3016260051837de189d49beff4f4a158cb2e7f41438641377e11d75c164f423e6a86d8b8fca3b76e2630611678525465d06c21b393f60
diff --git a/x11-misc/rofi/rofi-1.6.1.ebuild b/x11-misc/rofi/rofi-1.6.1.ebuild
new file mode 100644
index 000000000000..74b85e714b65
--- /dev/null
+++ b/x11-misc/rofi/rofi-1.6.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="A window switcher, run dialog and dmenu replacement"
+HOMEPAGE="https://github.com/davatorium/rofi"
+SRC_URI="https://github.com/davatorium/rofi/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="+drun test +windowmode"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/glib:2
+ gnome-base/librsvg:2
+ media-libs/freetype
+ virtual/jpeg
+ x11-libs/cairo[X,xcb(+)]
+ x11-libs/libXft
+ x11-libs/libXinerama
+ x11-libs/libxcb
+ x11-libs/libxkbcommon[X]
+ x11-libs/pango[X]
+ x11-libs/startup-notification
+ x11-libs/xcb-util
+ x11-libs/xcb-util-wm
+ x11-libs/xcb-util-xrm
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+ x11-base/xorg-proto
+ test? ( >=dev-libs/check-0.11 )
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.15.12-Werror.patch
+ "${FILESDIR}"/${PN}-1.5.0-gtk-settings-test.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ tc-export CC
+
+ econf \
+ $(use_enable drun) \
+ $(use_enable test check) \
+ $(use_enable windowmode)
+}