summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-01-03 21:32:25 +0100
committerConrad Kostecki <conikost@gentoo.org>2021-01-03 21:52:05 +0100
commitb19dfeadc09c51b1f7e84b055d54fdcf6651b9be (patch)
treee568c79dad0757aae0f5014bb2689a477ae3dd1b /x11-misc
parentsys-fs/cryptmount: bump to version 5.3.3 (diff)
downloadgentoo-b19dfeadc09c51b1f7e84b055d54fdcf6651b9be.tar.gz
gentoo-b19dfeadc09c51b1f7e84b055d54fdcf6651b9be.tar.bz2
gentoo-b19dfeadc09c51b1f7e84b055d54fdcf6651b9be.zip
x11-misc/mugshot: bump to version 0.4.3
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/mugshot/Manifest1
-rw-r--r--x11-misc/mugshot/mugshot-0.4.3.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/x11-misc/mugshot/Manifest b/x11-misc/mugshot/Manifest
index 8d2ac1852297..48e2bcc5beed 100644
--- a/x11-misc/mugshot/Manifest
+++ b/x11-misc/mugshot/Manifest
@@ -1 +1,2 @@
DIST mugshot-0.4.2.tar.gz 121020 BLAKE2B c092e25273dbd8ef9cbfbc001fb5f86b134ed8f9bf5d84993d5f46664f17eb74eda5c121ee70b5f0c4b0adb5aa1fc4d21d8c59d3f0cf4a4f67991d06690f5aa5 SHA512 721629cf4a7e4d84fd8505279cf88c88ac88c7b6c995ac84a2fd6a9b978c92716bbe20d7b0301ca70e99c007698e4cddf41b6cf1111bf496eec4d39591cd9ed1
+DIST mugshot-0.4.3.tar.gz 128500 BLAKE2B 88ed4a9a0efa70a14d90b831d00ad8c98d7c6dc4eff0e319e5ad08e904b0c0cf2c15bb26198f4ae1248e85959c08af165c9b6dc917dce35d986fdd73ff67eed8 SHA512 b5e91288b4de30124bd84c44b8f2a70e043af12e1f9580d07b13344b6c0343399037aadf153ea216d61cd12e4891ebb15557f1ad62c3b4d7c49584fa004ae65c
diff --git a/x11-misc/mugshot/mugshot-0.4.3.ebuild b/x11-misc/mugshot/mugshot-0.4.3.ebuild
new file mode 100644
index 000000000000..e739d980480c
--- /dev/null
+++ b/x11-misc/mugshot/mugshot-0.4.3.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS="no"
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1 gnome2-utils xdg-utils
+
+DESCRIPTION="A lightweight user-configuration application"
+HOMEPAGE="https://github.com/bluesabre/mugshot"
+SRC_URI="https://github.com/bluesabre/${PN}/archive/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnome libreoffice webcam"
+
+COMMON_DEPEND="
+ dev-libs/gobject-introspection
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+
+"
+
+RDEPEND="
+ ${COMMON_DEPEND}
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ sys-apps/accountsservice
+ sys-apps/shadow
+ gnome? ( gnome-base/gnome-control-center )
+ libreoffice? (
+ || (
+ app-office/libreoffice-bin
+ app-office/libreoffice
+ )
+ )
+ webcam? (
+ media-libs/gstreamer:1.0
+ media-libs/gst-plugins-good:1.0
+ gnome? (
+ media-libs/clutter-gtk[introspection]
+ media-video/cheese[introspection]
+ )
+ )
+"
+
+DEPEND="
+ ${COMMON_DEPEND}
+ x11-libs/gtk+:3[introspection]
+"
+
+BDEPEND="
+ dev-python/python-distutils-extra[${PYTHON_USEDEP}]
+ dev-util/intltool
+"
+
+S="${WORKDIR}/${PN}-${P}"
+
+python_install() {
+ distutils-r1_python_install
+
+ python_optimize
+
+ # Since DOCS are installed twice, remove the wrong path
+ rm -r "${ED}"/usr/share/doc/mugshot || die
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+ xdg_icon_cache_update
+}