summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrahmajit Das <brahmajit.xyz@gmail.com>2024-02-16 01:12:04 +0530
committerBernard Cafarelli <voyageur@gentoo.org>2024-02-16 09:19:51 +0100
commitb79ffd3a3cfdaf089817f5216ec7ea84ae4cd608 (patch)
treeb796c428525dc55d1cc99ef604fb6bb65f4b5ca6 /x11-misc
parentnet-dns/knot-resolver: drop vulnerable 5.7.0-r2 (diff)
downloadgentoo-b79ffd3a3cfdaf089817f5216ec7ea84ae4cd608.tar.gz
gentoo-b79ffd3a3cfdaf089817f5216ec7ea84ae4cd608.tar.bz2
gentoo-b79ffd3a3cfdaf089817f5216ec7ea84ae4cd608.zip
x11-misc/xscreensaver-app: Fix passing argument from incompatible pointer
And update EAPI 7 -> 8 Closes: https://bugs.gentoo.org/924177 Signed-off-by: Brahmajit Das <brahmajit.xyz@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/35353 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/xscreensaver-app/files/xscreensaver-app-2.3-gcc14-build-fix.patch12
-rw-r--r--x11-misc/xscreensaver-app/xscreensaver-app-2.3-r5.ebuild51
2 files changed, 63 insertions, 0 deletions
diff --git a/x11-misc/xscreensaver-app/files/xscreensaver-app-2.3-gcc14-build-fix.patch b/x11-misc/xscreensaver-app/files/xscreensaver-app-2.3-gcc14-build-fix.patch
new file mode 100644
index 000000000000..533a72386d8c
--- /dev/null
+++ b/x11-misc/xscreensaver-app/files/xscreensaver-app-2.3-gcc14-build-fix.patch
@@ -0,0 +1,12 @@
+Bug: https://bugs.gentoo.org/924177
+--- a/xscreensaver.app.c
++++ b/xscreensaver.app.c
+@@ -116,7 +116,7 @@ void popConfig()
+
+ int main(int argc, char **argv)
+ {
+- unsigned height, width;
++ unsigned short height, width;
+ char *st_command;
+ int status;
+
diff --git a/x11-misc/xscreensaver-app/xscreensaver-app-2.3-r5.ebuild b/x11-misc/xscreensaver-app/xscreensaver-app-2.3-r5.ebuild
new file mode 100644
index 000000000000..fd5b64aef202
--- /dev/null
+++ b/x11-misc/xscreensaver-app/xscreensaver-app-2.3-r5.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit autotools
+
+MY_PN=${PN/-a/.A}
+MY_PN=${MY_PN/xs/XS}
+MY_PN=${MY_PN/s/S}
+
+DESCRIPTION="XScreenSaver dockapp for the Window Maker window manager"
+HOMEPAGE="https://xscreensaverapp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/project/xscreensaverapp/${MY_PN}/${PV}/${MY_PN}-${PV}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+
+CDEPEND="
+ x11-libs/libdockapp
+ x11-libs/libX11
+"
+DEPEND="
+ ${CDEPEND}
+ virtual/pkgconfig
+ x11-base/xorg-proto
+"
+RDEPEND="
+ ${CDEPEND}
+ x11-misc/xscreensaver
+"
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.3-gcc14-build-fix.patch"
+)
+
+src_prepare() {
+ rm configure.in || die
+ cp "${FILESDIR}"/${PN}-2.3-configure.ac configure.ac || die
+
+ default
+
+ eautoreconf
+}
+
+src_install() {
+ dobin ${MY_PN}
+ dodoc README NEWS ChangeLog TODO AUTHORS
+}