summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-12-11 01:06:54 +0100
committerConrad Kostecki <conikost@gentoo.org>2021-12-11 01:08:28 +0100
commitc8d3e97a4df61fa88bdba278fb4411eb60b7712a (patch)
treec8e7cfaa61b6f9487eafed58d341d9ac51a167e9 /x11-misc
parentdev-lang/go: stable 1.17.5 on amd64 (diff)
downloadgentoo-c8d3e97a4df61fa88bdba278fb4411eb60b7712a.tar.gz
gentoo-c8d3e97a4df61fa88bdba278fb4411eb60b7712a.tar.bz2
gentoo-c8d3e97a4df61fa88bdba278fb4411eb60b7712a.zip
x11-misc/dunst: add 1.7.3
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/dunst/Manifest1
-rw-r--r--x11-misc/dunst/dunst-1.7.3.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/x11-misc/dunst/Manifest b/x11-misc/dunst/Manifest
index 14848b9ba096..fd28c54ceb46 100644
--- a/x11-misc/dunst/Manifest
+++ b/x11-misc/dunst/Manifest
@@ -1,2 +1,3 @@
DIST dunst-1.6.1.tar.gz 217267 BLAKE2B 267e5be6a079097fb5a677bd2451b0e5bcbcddadf4c4de9af87d4eab7dd90b61908f140db3f1238b6a79d370fc3bb89c062c6b4deeefae6c9c0069b55017e907 SHA512 079ffd0ff75f1865b68cb8db261849cbe4f68b5c632c39ef8f7a3d193ff3eba3734bca31cb7268f27c9a411aec56e4c484c383b419bc0b4755b7d80ede84cd96
DIST dunst-1.7.2.tar.gz 4595479 BLAKE2B b2e6c5a47ebc658160619c1fdfa2b4bf749a510d02f0552be842e24e8eff158e509dffc7df6b8e656545f4eaa7adb852b8e4d0d7d8a0a48435f734a1ee20cfc8 SHA512 1fc5837da2ff343d9badf2af2f91e32d79b91d3376b6cbe53ed9d73a248dc6dd7752a19523743b464121af329c81e69b02b03e3c5e0daa9e20afe6eb901f65dc
+DIST dunst-1.7.3.tar.gz 4596283 BLAKE2B dff61659b777a92cd2add9b15551a7fa471eb9adda47b31bd48d6b20a34192f3f9e7147a4249047f6993a595d0d0cf9895d9a7cc84f5bbc64972f4e111e924ad SHA512 e8bd8555bd9ea3dc5ae85c2459ad1fa29bbc5d575346381e828fc6efd618db1e87c40b4fceeb89aef83bb7f5df6b246d8a354ce8b13ec549f3452cb32c918d62
diff --git a/x11-misc/dunst/dunst-1.7.3.ebuild b/x11-misc/dunst/dunst-1.7.3.ebuild
new file mode 100644
index 000000000000..8eaab62529e9
--- /dev/null
+++ b/x11-misc/dunst/dunst-1.7.3.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit systemd toolchain-funcs
+
+DESCRIPTION="Lightweight replacement for common notification daemons"
+HOMEPAGE="https://dunst-project.org/ https://github.com/dunst-project/dunst"
+SRC_URI="https://github.com/dunst-project/dunst/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="wayland"
+
+DEPEND="
+ dev-libs/glib:2
+ sys-apps/dbus
+ x11-libs/cairo[X,glib]
+ x11-libs/gdk-pixbuf:2
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXScrnSaver
+ x11-libs/libXinerama
+ x11-libs/libXrandr
+ x11-libs/libnotify
+ x11-libs/pango[X]
+ x11-misc/xdg-utils
+ wayland? ( dev-libs/wayland )
+"
+
+RDEPEND="${DEPEND}"
+
+BDEPEND="
+ dev-lang/perl
+ virtual/pkgconfig
+ wayland? ( dev-libs/wayland-protocols )
+"
+
+src_prepare() {
+ default
+
+ # Respect users CFLAGS
+ sed -e 's/-Os//' -i config.mk || die
+
+ # Use correct path for dbus and system unit
+ sed -e "s|##PREFIX##|${EPREFIX}/usr|" -i dunst.systemd.service.in || die
+ sed -e "s|##PREFIX##|${EPREFIX}/usr|" -i org.knopwob.dunst.service.in || die
+}
+
+src_configure() {
+ tc-export CC PKG_CONFIG
+
+ default
+}
+
+src_compile() {
+ local myemakeargs=(
+ SYSTEMD="0"
+ WAYLAND="$(usex wayland 1 0)"
+ )
+
+ emake "${myemakeargs[@]}"
+}
+
+src_install() {
+ local myemakeargs=(
+ PREFIX="${ED}/usr"
+ SYSCONFDIR="${ED}/etc"
+ SYSTEMD="0"
+ WAYLAND="$(usex wayland 1 0)"
+ )
+
+ emake "${myemakeargs[@]}" install
+
+ systemd_newuserunit dunst.systemd.service.in dunst.service
+}