summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2018-02-04 22:56:36 +0100
committerJeroen Roovers <jer@gentoo.org>2018-02-04 23:31:12 +0100
commitc9411a79269a9adf2389eb0f1da66bc2877ce4de (patch)
treeb22f33d88d63e0c4ef3e8a4680eb1b2286b7417a /x11-misc
parentapp-benchmarks/wrk: Bump to version 4.1.0 (diff)
downloadgentoo-c9411a79269a9adf2389eb0f1da66bc2877ce4de.tar.gz
gentoo-c9411a79269a9adf2389eb0f1da66bc2877ce4de.tar.bz2
gentoo-c9411a79269a9adf2389eb0f1da66bc2877ce4de.zip
x11-misc/rofi: Version 1.5.0.
Package-Manager: Portage-2.3.20, Repoman-2.3.6
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/rofi/Manifest1
-rw-r--r--x11-misc/rofi/rofi-1.5.0.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/x11-misc/rofi/Manifest b/x11-misc/rofi/Manifest
index a4c3b58e4842..cd01d940dc33 100644
--- a/x11-misc/rofi/Manifest
+++ b/x11-misc/rofi/Manifest
@@ -1,3 +1,4 @@
DIST rofi-1.3.1.tar.xz 211732 BLAKE2B 60a217a47c547b1e59632356f4ddcb37144364a990974cbc013c53b21eae04e9568cc39e2ba6d2ea681501582910fb685bcb865cf011be0b2f00d986f4317c3e SHA512 a96c53ad268883277c4ff0ee3267ff7fab4d4a93a982019ce19ea82771b65c32d56216d777494853bffd18481400af72ed777f88cce4b26d7d1b8980a997f6c6
DIST rofi-1.4.1.tar.xz 337988 BLAKE2B 65867f4095dd82e62c955d7a3f5d86dcd84112dc8c530d22ebceed0b1c26b3e1c3be196cf2a1089e45ff11543eeed37abfe48a6007a85eed91b196f993064831 SHA512 3db3642819761bcfc99e7e8c6f09dde0c85d34be84541ac376ce09032a5c20aa7d64d6e12c9e21bfbee7d2db2611d24a12539548b662df6fb061d91cca1eb808
DIST rofi-1.4.2.tar.xz 339316 BLAKE2B f35bd60fb490ca9158a4b022bd972169626634adc1fa386b3b37e63497004d2fb0d85a711c4f4f7f377c377188ecc578de78c0c70bf21e086bc59c809a69bd05 SHA512 9f6cdde4b169c9f5471eb40cca9ce65ee2e87f541b0a9e48ce5ccc61d65930befbf152af667436a9142b36ba40c2be17c1aacc90deeff70e7f40dcaa1f9a9c8f
+DIST rofi-1.5.0.tar.xz 354232 BLAKE2B 2478902542b994ba06c4d436fa9436659366e2416e1a7a3ddd9a48e84d397faff963a4ac0c1bb1011a5f8a8440d1fc257377d28f556a60dc264b29eadadf5c7e SHA512 f24f93224f38e009307912dec19182a04b36a9ac88b26a8657d853cc040e1a59837a56a3e8ff08aa34143f455b5030c73fc28ced96123f3bc7e3943582aee81c
diff --git a/x11-misc/rofi/rofi-1.5.0.ebuild b/x11-misc/rofi/rofi-1.5.0.ebuild
new file mode 100644
index 000000000000..29016aeb7d09
--- /dev/null
+++ b/x11-misc/rofi/rofi-1.5.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools toolchain-funcs
+
+DESCRIPTION="A window switcher, run dialog and dmenu replacement"
+HOMEPAGE="https://github.com/DaveDavenport/rofi/"
+SRC_URI="${HOMEPAGE}/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test windowmode"
+
+RDEPEND="
+ dev-libs/glib:2
+ media-libs/freetype
+ x11-libs/cairo[xcb]
+ x11-libs/libXft
+ x11-libs/libXinerama
+ x11-libs/libxcb
+ x11-libs/libxkbcommon[X]
+ x11-libs/pango[X]
+ x11-libs/startup-notification
+ x11-libs/xcb-util
+ x11-libs/xcb-util-wm
+ x11-libs/xcb-util-xrm
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+ x11-proto/xineramaproto
+ x11-proto/xproto
+ test? ( >=dev-libs/check-0.11 )
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.15.12-Werror.patch
+)
+
+src_prepare() {
+ if use test; then
+ sed -i -e 's|"/tmp/rofi-test.pid"|"'"$T"'/rofi-test.pid"|g' test/helper-pidfile.c || die
+ fi
+
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ tc-export CC
+
+ econf \
+ $(use_enable test check) \
+ $(use_enable windowmode)
+}