summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-02-14 18:58:23 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-02-14 22:51:16 +0100
commitd38362c5c37d5fa8a8cfe31e5d074639fc47d110 (patch)
tree8bf5708e1e00517a31ccdfdecbc4c23c8f9c2731 /x11-misc
parentx11-misc/tint2: Drop 16.2, 16.6, 16.6.1 (diff)
downloadgentoo-d38362c5c37d5fa8a8cfe31e5d074639fc47d110.tar.gz
gentoo-d38362c5c37d5fa8a8cfe31e5d074639fc47d110.tar.bz2
gentoo-d38362c5c37d5fa8a8cfe31e5d074639fc47d110.zip
x11-misc/tint2: Port to cmake.eclass, drop superfluous phase functions
Fix DESCRIPTION to not contain PN. xdg_environment_reset is already called by cmake_src_prepare. Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/tint2/tint2-16.7.ebuild30
1 files changed, 6 insertions, 24 deletions
diff --git a/x11-misc/tint2/tint2-16.7.ebuild b/x11-misc/tint2/tint2-16.7.ebuild
index f71adacd17f3..41eb579f0bee 100644
--- a/x11-misc/tint2/tint2-16.7.ebuild
+++ b/x11-misc/tint2/tint2-16.7.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake-utils xdg
+inherit cmake xdg
-DESCRIPTION="tint2 is a lightweight panel/taskbar for Linux."
+DESCRIPTION="Lightweight panel/taskbar for Linux"
HOMEPAGE="https://gitlab.com/o9000/tint2"
SRC_URI="https://gitlab.com/o9000/${PN}/-/archive/v${PV}/${PN}-v${PV}.tar.gz"
S=${WORKDIR}/${PN}-v${PV}
@@ -13,7 +13,7 @@ S=${WORKDIR}/${PN}-v${PV}
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~ppc x86"
-IUSE="battery svg startup-notification tint2conf"
+IUSE="battery startup-notification svg tint2conf"
DEPEND="
dev-libs/glib:2
@@ -33,8 +33,7 @@ DEPEND="
RDEPEND="${DEPEND}"
src_prepare() {
- xdg_src_prepare
- cmake-utils_src_prepare
+ cmake_src_prepare
}
src_configure() {
@@ -45,22 +44,5 @@ src_configure() {
-DENABLE_SN="$(usex startup-notification)"
-DENABLE_RSVG="$(usex svg)"
)
-
- cmake-utils_src_configure
-}
-
-src_install() {
- cmake-utils_src_install
-}
-
-pkg_preinst() {
- xdg_pkg_preinst
-}
-
-pkg_postinst() {
- xdg_pkg_postinst
-}
-
-pkg_postrm() {
- xdg_pkg_postrm
+ cmake_src_configure
}