summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-09-04 12:35:01 +0200
committerJeroen Roovers <jer@gentoo.org>2020-09-04 12:35:31 +0200
commitf144e3f0f35045d4c2206796ffa379a5d5743f65 (patch)
tree79a873bb64c2e4b88e217cab755feb9cd9d57bcd /x11-misc
parentx11-misc/macopix: Version 3.4.0 (diff)
downloadgentoo-f144e3f0f35045d4c2206796ffa379a5d5743f65.tar.gz
gentoo-f144e3f0f35045d4c2206796ffa379a5d5743f65.tar.bz2
gentoo-f144e3f0f35045d4c2206796ffa379a5d5743f65.zip
x11-misc/hsetroot: Version 1.0.5
Package-Manager: Portage-3.0.5, Repoman-3.0.1 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/hsetroot/Manifest1
-rw-r--r--x11-misc/hsetroot/files/hsetroot-1.0.5-XOpenDisplay.patch15
-rw-r--r--x11-misc/hsetroot/hsetroot-1.0.5.ebuild56
3 files changed, 72 insertions, 0 deletions
diff --git a/x11-misc/hsetroot/Manifest b/x11-misc/hsetroot/Manifest
index a110d242c4e7..237e0b3b298c 100644
--- a/x11-misc/hsetroot/Manifest
+++ b/x11-misc/hsetroot/Manifest
@@ -1,3 +1,4 @@
DIST hsetroot-1.0.2.tar.gz 125535 BLAKE2B 351c022e11e3d82118db451eb6d64ff765018a09fe1ac9cc3b437f7a351d575fca66619fde9671d297b346af7c7f265442d18115388d984554bf1f9af9fbe82d SHA512 51788a6b579b82368ef5e11255ff56e2db978a02f7ad752ba64ec33c56ae5f27c1f0ef3452725d1c7bdb9d97b8a3a5b64422031c9c75a7279c407b8772d5edc3
+DIST hsetroot-1.0.5.tar.gz 12878 BLAKE2B 54e80f00d140a83a950d98663db6555a00ac770bd85826b17d8293e3af27cba2a45c2da5e4c185ca90c6adc35bbf2ccdaa3722d015b31654d5e35f4e65a61366 SHA512 b43f7cd75886e72cb6134446d383d7d9a684c818f2d8a0f829670c8dfca5eaaa1eb6c25f30dda41f3483609b25e8a44a3a3cb3a969bba7f77a9b9df712fa2167
DIST hsetroot_1.0.2-5.debian.tar.xz 4384 BLAKE2B 5ea72b6017a90bdf36030334c021cef1000ca29370f359f2596feea69365ebe5bd6b58286b109ca63a16dc953aea1f873ee4a7eadd50432655093d2dd7e6249d SHA512 5f1dbb00daebf6b8c9db77a51dbc463ea92b4564e0d7a2dac1ea9c316dd2e2126fb8c6454f4d1eddfd19533297e29651444987a7eacb7c0080e26c14383c827d
DIST hsetroot_1.0.2.orig.tar.gz 125621 BLAKE2B 932acda46653d2211c528008dad14c8877b0b6ace0888da19e1316af58a39b0cde0464f5dd058b752d7d95dd6d69deefc254a0a445e37077c4b177ddedf74809 SHA512 cac98cc602fd8825dbfce27d289dc4ba47805c99c78de804e95c539e83ffae6984601a535cdb90658536a007a5f17c71e27e4c31af562ade6610f11f0d0d2ca5
diff --git a/x11-misc/hsetroot/files/hsetroot-1.0.5-XOpenDisplay.patch b/x11-misc/hsetroot/files/hsetroot-1.0.5-XOpenDisplay.patch
new file mode 100644
index 000000000000..0585072538f2
--- /dev/null
+++ b/x11-misc/hsetroot/files/hsetroot-1.0.5-XOpenDisplay.patch
@@ -0,0 +1,15 @@
+--- a/hsr-outputs.c
++++ b/hsr-outputs.c
+@@ -47,7 +47,11 @@
+ int
+ main(int argc, char **argv)
+ {
+- Display *display = XOpenDisplay(NULL);
++ Display *display;
++ if (!(display = XOpenDisplay(NULL))) {
++ fprintf(stderr, "Cannot open X display!\n");
++ exit(123);
++ }
+
+ enum Format format = TEXT;
+ void (*print)(XineramaScreenInfo*) = print_text;
diff --git a/x11-misc/hsetroot/hsetroot-1.0.5.ebuild b/x11-misc/hsetroot/hsetroot-1.0.5.ebuild
new file mode 100644
index 000000000000..cde4912ca941
--- /dev/null
+++ b/x11-misc/hsetroot/hsetroot-1.0.5.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DESCRIPTION="Tool which allows you to compose wallpapers ('root pixmaps') for X"
+HOMEPAGE="https://github.com/himdel/hsetroot/"
+SRC_URI="
+ https://github.com/himdel/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+
+RDEPEND="
+ >=media-libs/imlib2-1.0.6.2003[X]
+ x11-libs/libX11
+ x11-libs/libXinerama
+"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+DOCS="AUTHORS ChangeLog NEWS README"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0.5-XOpenDisplay.patch
+)
+
+src_compile() {
+ # Avoid the Makefile that replaced autotools
+ tc-export CC PKG_CONFIG
+ local tgt hsr_comp_args
+ for tgt in ${PN} hsr-outputs; do
+ hsr_comp_args=(
+ ${CFLAGS}
+ $("${PKG_CONFIG}" --cflags x11 imlib2 xinerama)
+ ${LDFLAGS}
+ ${tgt}.c
+ $("${PKG_CONFIG}" --libs x11 imlib2 xinerama)
+ -o ${tgt}
+ )
+ echo ${hsr_comp_args[@]}
+ "${CC}" ${hsr_comp_args[@]} || die
+ done
+
+}
+
+src_install() {
+ dobin ${PN} hsr-outputs
+ dodoc README.md
+}