summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2021-12-18 16:42:06 +0100
committerFlorian Schmaus <flow@gentoo.org>2021-12-18 16:42:18 +0100
commitf67843468c4c9e12a9790f4ef2b5e9f901cda23c (patch)
tree4b56f034ee4bed2a042a1036a5ddaf18086cb16f /x11-misc
parentdev-vcs/mercurial: remove unsupported tests on big-endian (diff)
downloadgentoo-f67843468c4c9e12a9790f4ef2b5e9f901cda23c.tar.gz
gentoo-f67843468c4c9e12a9790f4ef2b5e9f901cda23c.tar.bz2
gentoo-f67843468c4c9e12a9790f4ef2b5e9f901cda23c.zip
x11-misc/autorandr: add 1.12
Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/autorandr/Manifest1
-rw-r--r--x11-misc/autorandr/autorandr-1.12.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/x11-misc/autorandr/Manifest b/x11-misc/autorandr/Manifest
index 6523b0b03b90..13970e6a81f7 100644
--- a/x11-misc/autorandr/Manifest
+++ b/x11-misc/autorandr/Manifest
@@ -1 +1,2 @@
DIST autorandr-1.11.tar.gz 48791 BLAKE2B 57203b15eebdecab943c706745701e8569eb0a66dab69ae4429abfa863da736a5ed8b5333f6d948bcf8cae30f48c68eb1b35f2e84080526c1507ab78dba02efb SHA512 93de0461653aa5145956a8aafdc9fb257491495ca335e4213e7b6f1f313ebfd2332c38615ac648204494026439d77861a7eefd97e80cd49a5fe3d9b75db54ec1
+DIST autorandr-1.12.tar.gz 45511 BLAKE2B 513b197783a527d6ebe7ab1ef2d15bda64b9a3934e9e47ece41a84bb224509b68b9483d2be2e61ea5f07e9de7c1d1a1f8587ff1dded28843022e537a315cb34a SHA512 cd3a16932b6183055e991462cdef78e0b345b64fb2b1ea4a28d5e7119ce5d8b4206bd4ee17288e104fe8fb5608a9eddb2efa5f7bfd3854b308ccbe476f50e9ee
diff --git a/x11-misc/autorandr/autorandr-1.12.ebuild b/x11-misc/autorandr/autorandr-1.12.ebuild
new file mode 100644
index 000000000000..392d59491a57
--- /dev/null
+++ b/x11-misc/autorandr/autorandr-1.12.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} )
+
+inherit bash-completion-r1 distutils-r1 systemd udev
+
+if [[ "${PV}" = "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/phillipberndt/${PN}.git"
+else
+ SRC_URI="https://github.com/phillipberndt/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Automatically select a display configuration based on connected devices"
+HOMEPAGE="https://github.com/phillipberndt/autorandr"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="launcher udev"
+
+RDEPEND="
+ x11-apps/xrandr
+ launcher? ( x11-libs/libxcb )
+ udev? ( virtual/udev )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_compile() {
+ distutils-r1_src_compile
+
+ if use launcher; then
+ emake contrib/autorandr_launcher/autorandr-launcher
+ fi
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ doman autorandr.1
+
+ local targets=(
+ autostart_config
+ bash_completion
+ systemd
+ $(usev launcher)
+ $(usev udev)
+ )
+
+ emake DESTDIR="${D}" \
+ BASH_COMPLETIONS_DIR="$(get_bashcompdir)" \
+ SYSTEMD_UNIT_DIR="$(systemd_get_systemunitdir)" \
+ UDEV_RULES_DIR="$(get_udevdir)"/rules.d \
+ $(printf "install_%s " "${targets[@]}")
+}
+
+pkg_postinst() {
+ if use udev; then
+ udev_reload
+ fi
+}