summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2022-04-14 16:03:46 +0300
committerSam James <sam@gentoo.org>2022-05-15 00:11:54 +0000
commitfe524b2f2966bbdb8870eba8a3ddf633d450883a (patch)
tree111e529e714d5673cab0282f3a16ae4671a3cca8 /x11-misc
parentapp-misc/astrolog-ephemeris: use HTTPS (diff)
downloadgentoo-fe524b2f2966bbdb8870eba8a3ddf633d450883a.tar.gz
gentoo-fe524b2f2966bbdb8870eba8a3ddf633d450883a.tar.bz2
gentoo-fe524b2f2966bbdb8870eba8a3ddf633d450883a.zip
x11-misc/obconf-qt: add version 0.16.2
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/obconf-qt/Manifest1
-rw-r--r--x11-misc/obconf-qt/obconf-qt-0.16.2.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/x11-misc/obconf-qt/Manifest b/x11-misc/obconf-qt/Manifest
index 073756acf16a..39ee0abe4593 100644
--- a/x11-misc/obconf-qt/Manifest
+++ b/x11-misc/obconf-qt/Manifest
@@ -1 +1,2 @@
DIST obconf-qt-0.16.0.tar.xz 101588 BLAKE2B 94407df40878c64a40343ad2a8fdbebc78a99beaf017485fda52d6043f2597467c67da465dd191a78ba7c084f1072152d4033f7b5b41f257946941efda37a9e3 SHA512 ab0ddc013ca877f2434da956c314b248f6a7ef5ced1e5c605de0652d0b8c5c0e84f1e6fdf8b21c6f3d450d57a1413d625d0a31b84cac2c9062dc0f101d8e57ab
+DIST obconf-qt-0.16.2.tar.xz 111080 BLAKE2B 1ea6d4f5afb3e34db288bb1cfeb0c76345704b592230ebbaaff464206b13b9dfde7ff0ae07dd164e1d925e93e51a9a9bd6c571f55b81f3bbfc1537bfa620f521 SHA512 bd91a5669f07471966d296b91d78e2a40e2e3640405de2179513457088eb7d6cb063dbfaff623db6f404985734e986b52c1e3155a050f374b7afa58f7d720c0d
diff --git a/x11-misc/obconf-qt/obconf-qt-0.16.2.ebuild b/x11-misc/obconf-qt/obconf-qt-0.16.2.ebuild
new file mode 100644
index 000000000000..0ea4ab64be46
--- /dev/null
+++ b/x11-misc/obconf-qt/obconf-qt-0.16.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg-utils
+
+DESCRIPTION="Qt GUI Openbox Configuration Tool"
+HOMEPAGE="https://lxqt.github.io/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="GPL-2 GPL-2+"
+SLOT="0"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ >=dev-util/lxqt-build-tools-0.8.0
+ sys-apps/sed
+ virtual/pkgconfig
+"
+RDEPEND="
+ dev-libs/glib:2
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ x11-libs/libX11
+ x11-wm/openbox:3
+"
+DEPEND="${RDEPEND}"
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}