summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2016-08-28 12:32:07 -0400
committerMichael Orlitzky <mjo@gentoo.org>2016-08-28 12:36:46 -0400
commit01fa5298a358a092d7f328b454af09dc6ed020c3 (patch)
tree4c20a0d231232bebbe7cd3a9765ad998f2fe23b1 /x11-plugins/asmem/files
parentapp-admin/calamares: Remove 2.2.3 (diff)
downloadgentoo-01fa5298a358a092d7f328b454af09dc6ed020c3.tar.gz
gentoo-01fa5298a358a092d7f328b454af09dc6ed020c3.tar.bz2
gentoo-01fa5298a358a092d7f328b454af09dc6ed020c3.zip
x11-plugins/asmem: new EAPI=6 revision that respects LDFLAGS.
This new revision is based on the ebuild supplied by Michael Mair-Keimberger in bug 334771. I turned his sed command into a patch, and further updated the ebuild to EAPI=6. Gentoo-Bug: 334771 Package-Manager: portage-2.2.28
Diffstat (limited to 'x11-plugins/asmem/files')
-rw-r--r--x11-plugins/asmem/files/respect-ldflags.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/x11-plugins/asmem/files/respect-ldflags.patch b/x11-plugins/asmem/files/respect-ldflags.patch
new file mode 100644
index 000000000000..75deb42eb75a
--- /dev/null
+++ b/x11-plugins/asmem/files/respect-ldflags.patch
@@ -0,0 +1,27 @@
+From 1f02c866884bd08dda27aada5ebaa92e560144d4 Mon Sep 17 00:00:00 2001
+From: Michael Orlitzky <michael@orlitzky.com>
+Date: Sun, 28 Aug 2016 12:15:34 -0400
+Subject: [PATCH 1/1] autoconf/Makefile.common.in: add $LDFLAGS to the linker
+ command.
+
+Gentoo-Bug: 334771
+---
+ autoconf/Makefile.common.in | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/autoconf/Makefile.common.in b/autoconf/Makefile.common.in
+index 2409579..08e01a9 100644
+--- a/autoconf/Makefile.common.in
++++ b/autoconf/Makefile.common.in
+@@ -34,7 +34,7 @@ indent:
+ done
+
+ $(PROG): $(OBJS)
+- $(CC) $(OBJS) $(LIBRARIES) $(EXTRA_LIBRARIES) -o $(@)
++ $(CC) $(OBJS) $(LIBRARIES) $(EXTRA_LIBRARIES) -o $(@) $(LDFLAGS)
+
+ .c.o:
+ $(CC) $(CCFLAGS) $(EXTRA_DEFINES) $(INCLUDES) $(EXTRA_INCLUDES) -c $*.c
+--
+2.7.3
+