summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-09-18 02:25:54 +0100
committerSam James <sam@gentoo.org>2022-09-18 02:26:07 +0100
commitc866f812d4ed8fd185016b97b5fdc9ac6a43d458 (patch)
tree7b849372f0ec517f1711ee5fd8bd55573c7279ee /x11-plugins/asmem
parentnet-misc/rwhoisd: add github upstream metadata (diff)
downloadgentoo-c866f812d4ed8fd185016b97b5fdc9ac6a43d458.tar.gz
gentoo-c866f812d4ed8fd185016b97b5fdc9ac6a43d458.tar.bz2
gentoo-c866f812d4ed8fd185016b97b5fdc9ac6a43d458.zip
x11-plugins/asmem: update EAPI 6 -> 8, fix implicit func. declarations
Closes: https://bugs.gentoo.org/870679 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-plugins/asmem')
-rw-r--r--x11-plugins/asmem/asmem-1.12-r2.ebuild (renamed from x11-plugins/asmem/asmem-1.12-r1.ebuild)26
-rw-r--r--x11-plugins/asmem/files/configure-implicit-func-decls.patch14
2 files changed, 31 insertions, 9 deletions
diff --git a/x11-plugins/asmem/asmem-1.12-r1.ebuild b/x11-plugins/asmem/asmem-1.12-r2.ebuild
index b8aeeafc0159..47c255eede9c 100644
--- a/x11-plugins/asmem/asmem-1.12-r1.ebuild
+++ b/x11-plugins/asmem/asmem-1.12-r2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit toolchain-funcs
@@ -14,16 +14,23 @@ SLOT="0"
KEYWORDS="amd64 ppc ppc64 sparc x86"
IUSE="jpeg"
-RDEPEND="x11-libs/libX11
+RDEPEND="
+ x11-libs/libX11
x11-libs/libICE
x11-libs/libSM
x11-libs/libXpm
x11-libs/libXext
- jpeg? ( virtual/jpeg:0 )"
-DEPEND="${RDEPEND}
- x11-base/xorg-proto"
-
-PATCHES=( "${FILESDIR}/respect-ldflags.patch" )
+ jpeg? ( media-libs/libjpeg-turbo:= )
+"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+"
+
+PATCHES=(
+ "${FILESDIR}"/respect-ldflags.patch
+ "${FILESDIR}"/configure-implicit-func-decls.patch
+)
src_configure() {
econf $(use_enable jpeg)
@@ -34,7 +41,8 @@ src_compile() {
}
src_install() {
- dobin "${PN}"
- newman "${PN}.man" "${PN}.1"
einstalldocs
+
+ dobin ${PN}
+ newman ${PN}.man ${PN}.1
}
diff --git a/x11-plugins/asmem/files/configure-implicit-func-decls.patch b/x11-plugins/asmem/files/configure-implicit-func-decls.patch
new file mode 100644
index 000000000000..0361c3e6e9b4
--- /dev/null
+++ b/x11-plugins/asmem/files/configure-implicit-func-decls.patch
@@ -0,0 +1,14 @@
+https://bugs.gentoo.org/870679
+
+Generated file and configure.in is written for autoconf 2.13.
+--- a/configure
++++ b/configure
+@@ -751,7 +751,7 @@ cat > conftest.$ac_ext << EOF
+ #line 752 "configure"
+ #include "confdefs.h"
+
+-main(){return(0);}
++int main(){return(0);}
+ EOF
+ if { (eval echo configure:757: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
+ ac_cv_prog_cc_works=yes