summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-03-25 17:40:49 +0100
committerThomas Deutschmann <whissi@gentoo.org>2020-03-25 17:41:27 +0100
commit3fe9da9fdba4143d89df7f86898af4e12fd779c2 (patch)
treea707b29621a58f9aeb5265d878e46e9a81f697bb /x11-plugins/enigmail/enigmail-2.0.12-r1.ebuild
parentdev-go/get-ego-vendor: update description (diff)
downloadgentoo-3fe9da9fdba4143d89df7f86898af4e12fd779c2.tar.gz
gentoo-3fe9da9fdba4143d89df7f86898af4e12fd779c2.tar.bz2
gentoo-3fe9da9fdba4143d89df7f86898af4e12fd779c2.zip
x11-plugins/enigmail: security cleanup (bug #706134)
Bug: https://bugs.gentoo.org/706134 Package-Manager: Portage-2.3.94, Repoman-2.3.21 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'x11-plugins/enigmail/enigmail-2.0.12-r1.ebuild')
-rw-r--r--x11-plugins/enigmail/enigmail-2.0.12-r1.ebuild84
1 files changed, 0 insertions, 84 deletions
diff --git a/x11-plugins/enigmail/enigmail-2.0.12-r1.ebuild b/x11-plugins/enigmail/enigmail-2.0.12-r1.ebuild
deleted file mode 100644
index 231c774dd69d..000000000000
--- a/x11-plugins/enigmail/enigmail-2.0.12-r1.ebuild
+++ /dev/null
@@ -1,84 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python2_7 )
-
-inherit python-any-r1
-
-DESCRIPTION="Mozilla extension to provide GPG support in mail clients"
-HOMEPAGE="https://www.enigmail.net/"
-
-SLOT="0"
-LICENSE="MPL-2.0 GPL-3"
-IUSE=""
-if [[ ${PV} == *9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://git.code.sf.net/p/enigmail/source"
- S="${WORKDIR}/${P}"
-else
- if [[ ${PV} = *_beta* ]] ; then
- SRC_URI="https://www.enigmail.net/download/beta/${P/_/-}.tar.gz"
- else
- SRC_URI="https://www.enigmail.net/download/source/${P}.tar.gz"
- KEYWORDS="~alpha amd64 ~arm ppc ppc64 x86 ~amd64-linux ~x86-linux"
- fi
- S="${WORKDIR}/${PN}"
-fi
-
-RDEPEND="
- ( >=app-crypt/gnupg-2.0
- || (
- app-crypt/pinentry[gtk(-)]
- app-crypt/pinentry[qt5(-)]
- )
- )
- !<mail-client/thunderbird-52.5.0
-"
-DEPEND="${RDEPEND}
- ${PYTHON_DEPS}
- app-arch/zip
- dev-lang/perl
- "
-
-PATCHES=(
- "${FILESDIR}"/enigmail-no_pEp_auto_download.patch
- "${FILESDIR}/${PN}-2.0.12-enable_seamonkey_support.patch"
-)
-
-src_compile() {
- emake ipc public ui package lang stdlib
- emake xpi
-
-}
-
-src_install() {
- local emid=$(sed -n '/<em:id>/!d; s/.*\({.*}\).*/\1/; p; q' build/dist/install.rdf)
- [[ -n ${emid} ]] || die "Could not scrape EM:ID from install.rdf"
-
- mv build/enigmail*.xpi build/"${emid}.xpi" || die 'Could not rename XPI to match EM:ID'
-
- # thunderbird
- insinto "/usr/share/mozilla/extensions/{3550f703-e582-4d05-9a08-453d09bdfdc6}"
- doins build/"${emid}.xpi"
-
- # seamonkey
- insinto "/usr/share/mozilla/extensions/{92650c4d-4b8e-4d2a-b7eb-24ecf4f6b63a}"
- doins build/"${emid}.xpi"
-}
-
-pkg_postinst() {
- local peimpl=$(eselect --brief --colour=no pinentry show)
- case "${peimpl}" in
- *gtk*|*qt*) ;;
- *) ewarn "The pinentry front-end currently selected is not one supported by thunderbird."
- ewarn "You may be prompted for your password in an inaccessible shell!!"
- ewarn "Please use 'eselect pinentry' to select either the gtk or qt front-end"
- ;;
- esac
- if [[ -n ${REPLACING_VERSIONS} ]]; then
- elog
- elog "Please restart thunderbird and/or seamonkey in order for them to use"
- elog "the newly installed version of enigmail."
- fi
-}