summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2016-04-14 11:41:25 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2016-04-14 11:42:04 +0200
commitf40d7ea3332168feea08e71173fd91582edc7258 (patch)
tree6a10a487743816f694e91f2bada40f9fc1c9f1c9 /x11-plugins/fsviewer
parentsci-physics/lammps: Version bump (diff)
downloadgentoo-f40d7ea3332168feea08e71173fd91582edc7258.tar.gz
gentoo-f40d7ea3332168feea08e71173fd91582edc7258.tar.bz2
gentoo-f40d7ea3332168feea08e71173fd91582edc7258.zip
x11-plugins/fsviewer: fix compilation with gcc5, EAPI6 update
Package-Manager: portage-2.2.28
Diffstat (limited to 'x11-plugins/fsviewer')
-rw-r--r--x11-plugins/fsviewer/files/fsviewer-0.2.6-configure.patch4
-rw-r--r--x11-plugins/fsviewer/files/fsviewer-0.2.6-gcc5.patch11
-rw-r--r--x11-plugins/fsviewer/fsviewer-0.2.6-r2.ebuild51
3 files changed, 64 insertions, 2 deletions
diff --git a/x11-plugins/fsviewer/files/fsviewer-0.2.6-configure.patch b/x11-plugins/fsviewer/files/fsviewer-0.2.6-configure.patch
index 61640e0cda75..2d1759fefce5 100644
--- a/x11-plugins/fsviewer/files/fsviewer-0.2.6-configure.patch
+++ b/x11-plugins/fsviewer/files/fsviewer-0.2.6-configure.patch
@@ -1,5 +1,5 @@
---- configure.ac.orig 2007-10-13 23:54:47.000000000 +0200
-+++ configure.ac 2015-09-02 21:10:40.829519545 +0200
+--- fsviewer-app-0.2.6.orig/configure.ac 2007-10-13 23:54:47.000000000 +0200
++++ fsviewer-app-0.2.6/configure.ac 2015-09-02 21:10:40.829519545 +0200
@@ -26,15 +26,15 @@
dnl look for X windows first so further libs check
AC_PATH_X
diff --git a/x11-plugins/fsviewer/files/fsviewer-0.2.6-gcc5.patch b/x11-plugins/fsviewer/files/fsviewer-0.2.6-gcc5.patch
new file mode 100644
index 000000000000..2a532625ff8c
--- /dev/null
+++ b/x11-plugins/fsviewer/files/fsviewer-0.2.6-gcc5.patch
@@ -0,0 +1,11 @@
+--- fsviewer-app-0.2.6.orig/src/list.h
++++ fsviewer-app-0.2.6/src/list.h
+@@ -29,7 +29,7 @@
+ #ifndef __LIST_H_
+ #define __LIST_H_
+
+-#if defined(__GNUC__) && !defined(__STRICT_ANSI__)
++#if defined(__GNUC__) && !defined(__STRICT_ANSI__) && (__GNUC__ < 5)
+ # define INLINE inline
+ #else
+ # define INLINE
diff --git a/x11-plugins/fsviewer/fsviewer-0.2.6-r2.ebuild b/x11-plugins/fsviewer/fsviewer-0.2.6-r2.ebuild
new file mode 100644
index 000000000000..0185fc13fe93
--- /dev/null
+++ b/x11-plugins/fsviewer/fsviewer-0.2.6-r2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit autotools multilib
+
+MY_P=${PN}-app-${PV}
+
+DESCRIPTION="A file system viewer for Window Maker"
+HOMEPAGE="http://www.bayernline.de/~gscholz/linux/fsviewer/"
+SRC_URI="http://www.bayernline.de/~gscholz/linux/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="nls"
+
+RDEPEND=">=x11-wm/windowmaker-0.95.2
+ x11-libs/libXft
+ x11-libs/libXpm
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ x11-proto/xproto
+ nls? ( sys-devel/gettext )"
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=(
+ "${FILESDIR}"/${P}-configure.patch
+ "${FILESDIR}"/${P}-gcc5.patch
+ "${FILESDIR}"/${P}-wmaker-0.95_support.patch
+ "${FILESDIR}"/${P}-fix_title_bar.patch
+)
+DOCS="AUTHORS ChangeLog NEWS README"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ --with-appspath=/usr/$(get_libdir)/GNUstep
+}
+
+src_install() {
+ default
+ dosym /usr/$(get_libdir)/GNUstep/FSViewer.app/FSViewer /usr/bin/FSViewer
+}