summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2017-07-26 12:42:22 +0200
committerPacho Ramos <pacho@gentoo.org>2017-07-26 13:34:13 +0200
commit2f326fb87263b4fa878986f89f97fae363ed4dad (patch)
tree5439a597f295e45e5eff4de65cbfd5bf58eb0f8b /x11-plugins/gkrellm-bluez/gkrellm-bluez-0.2-r2.ebuild
parentx11-plugins/gkrellm-bgchanger: Drop old (diff)
downloadgentoo-2f326fb87263b4fa878986f89f97fae363ed4dad.tar.gz
gentoo-2f326fb87263b4fa878986f89f97fae363ed4dad.tar.bz2
gentoo-2f326fb87263b4fa878986f89f97fae363ed4dad.zip
x11-plugins/gkrellm-bluez: Fix dependency on gkrellm[X]
Package-Manager: Portage-2.3.6, Repoman-2.3.2 RepoMan-Options: --force
Diffstat (limited to 'x11-plugins/gkrellm-bluez/gkrellm-bluez-0.2-r2.ebuild')
-rw-r--r--x11-plugins/gkrellm-bluez/gkrellm-bluez-0.2-r2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/x11-plugins/gkrellm-bluez/gkrellm-bluez-0.2-r2.ebuild b/x11-plugins/gkrellm-bluez/gkrellm-bluez-0.2-r2.ebuild
new file mode 100644
index 000000000000..9a6bd8488cca
--- /dev/null
+++ b/x11-plugins/gkrellm-bluez/gkrellm-bluez-0.2-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gkrellm-plugin
+
+DESCRIPTION="GKrellm plugin for monitoring bluetooth (Linux BlueZ) adapters"
+SRC_URI="mirror://sourceforge/gkrellm-bluez/${P}.tar.gz"
+HOMEPAGE="http://gkrellm-bluez.sourceforge.net"
+
+RDEPEND="
+ app-admin/gkrellm[X]
+ net-wireless/bluez
+"
+
+LICENSE="GPL-2"
+KEYWORDS="amd64 x86"
+IUSE=""
+SLOT="0"
+
+PLUGIN_SO="src/.libs/gkrellmbluez.so"
+PLUGIN_DOCS="THEMING NEWS"
+
+src_prepare() {
+ default
+ # Be a bit more future proof, bug #260948
+ sed "s/-Werror//" -i src/Makefile.am src/Makefile.in || die "sed failed"
+
+ eapply "${FILESDIR}"/${P}-notheme.patch || die "Patch failed"
+}
+
+src_configure() {
+ econf --disable-static
+}