summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2017-07-26 12:44:24 +0200
committerPacho Ramos <pacho@gentoo.org>2017-07-26 13:34:16 +0200
commiteba8d6b751fc3be8e147bad98b17085213ee0dbe (patch)
tree0d3ff541ef6d177c951bc6aa6e5e094133a92ee1 /x11-plugins/gkrellm-cpupower/gkrellm-cpupower-0.2-r1.ebuild
parentx11-plugins/gkrellm-bluez: Drop old (diff)
downloadgentoo-eba8d6b751fc3be8e147bad98b17085213ee0dbe.tar.gz
gentoo-eba8d6b751fc3be8e147bad98b17085213ee0dbe.tar.bz2
gentoo-eba8d6b751fc3be8e147bad98b17085213ee0dbe.zip
x11-plugins/gkrellm-cpupower: Fix dependency on gkrellm[X]
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'x11-plugins/gkrellm-cpupower/gkrellm-cpupower-0.2-r1.ebuild')
-rw-r--r--x11-plugins/gkrellm-cpupower/gkrellm-cpupower-0.2-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/x11-plugins/gkrellm-cpupower/gkrellm-cpupower-0.2-r1.ebuild b/x11-plugins/gkrellm-cpupower/gkrellm-cpupower-0.2-r1.ebuild
new file mode 100644
index 000000000000..f8679d71309f
--- /dev/null
+++ b/x11-plugins/gkrellm-cpupower/gkrellm-cpupower-0.2-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gkrellm-plugin
+
+MY_P="${P/gkrellm/gkrellm2}"
+
+DESCRIPTION="A Gkrellm2 plugin for displaying and manipulating CPU frequency"
+HOMEPAGE="https://github.com/sainsaar/gkrellm2-cpupower/"
+SRC_URI="https://github.com/sainsaar/gkrellm2-cpupower/archive/${PV}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_P}"
+
+RDEPEND="
+ app-admin/gkrellm[X]
+ app-admin/sudo
+ sys-power/cpupower
+"
+
+PLUGIN_SO="cpupower.so"
+
+src_install() {
+ gkrellm-plugin_src_install
+ emake DESTDIR="${D}" install-sudo
+}
+
+pkg_postinst() {
+ echo
+ einfo "For changing the governor and CPU frequencies as a user, create the \"trusted\""
+ einfo "group, and add those users to that group who should be allowed to perform"
+ einfo "these changes."
+ echo
+}