summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2016-08-07 00:06:55 -0400
committerMichael Orlitzky <mjo@gentoo.org>2016-08-07 00:07:13 -0400
commit51d8d2f1eaf8ca67459dddeed5dc6ce584fc1a46 (patch)
tree87ee66d099783dbc1cfc6d2fcc70f2a170775904 /x11-plugins/gkrellm-imonc/gkrellm-imonc-0.2-r1.ebuild
parentapp-vim/csound-syntax: version bump to 20160804 (diff)
downloadgentoo-51d8d2f1eaf8ca67459dddeed5dc6ce584fc1a46.tar.gz
gentoo-51d8d2f1eaf8ca67459dddeed5dc6ce584fc1a46.tar.bz2
gentoo-51d8d2f1eaf8ca67459dddeed5dc6ce584fc1a46.zip
x11-plugins/gkrellm-imonc: new revision that respects LDFLAGS.
This is another revision thanks to Michael Mair-Keimberger. His patch fixes the Makefile so that it adds $(LDFLAGS) in the right spots, and also happens to fix $(CC) in the process. An EAPI=2 USE-dependency was added for gkrellm (also part of the patch), and the ebuild was updated to use EAPI=6. Gentoo-Bug: 335013 Package-Manager: portage-2.2.28
Diffstat (limited to 'x11-plugins/gkrellm-imonc/gkrellm-imonc-0.2-r1.ebuild')
-rw-r--r--x11-plugins/gkrellm-imonc/gkrellm-imonc-0.2-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/x11-plugins/gkrellm-imonc/gkrellm-imonc-0.2-r1.ebuild b/x11-plugins/gkrellm-imonc/gkrellm-imonc-0.2-r1.ebuild
new file mode 100644
index 000000000000..856afe740e97
--- /dev/null
+++ b/x11-plugins/gkrellm-imonc/gkrellm-imonc-0.2-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit gkrellm-plugin
+
+DESCRIPTION="A GKrellM2 plugin to control a fli4l router"
+SRC_URI="mirror://sourceforge/${PN}/${PN}-src-${PV}.tar.bz2"
+HOMEPAGE="http://${PN}.sourceforge.net/"
+
+# The COPYING file contains the GPLv2, but the file headers say GPLv2+.
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+COMMON_DEPEND="app-admin/gkrellm[X]"
+DEPEND+=" ${COMMON_DEPEND}"
+RDEPEND+=" ${COMMON_DEPEND}"
+
+S="${WORKDIR}/${PN}-src-${PV}"
+
+PATCHES=( "${FILESDIR}/${PN}-makefile.patch" )
+
+src_compile() {
+ emake CC="$(tc-getCC)" LDFLAGS="${LDFLAGS}"
+}