summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-plugins/gkrellm-volume/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-plugins/gkrellm-volume/files')
-rw-r--r--x11-plugins/gkrellm-volume/files/gkrellm-volume-2.1.13-Respect-LDFLAGS.patch13
-rw-r--r--x11-plugins/gkrellm-volume/files/gkrellm-volume-2.1.13-reenable.patch14
2 files changed, 27 insertions, 0 deletions
diff --git a/x11-plugins/gkrellm-volume/files/gkrellm-volume-2.1.13-Respect-LDFLAGS.patch b/x11-plugins/gkrellm-volume/files/gkrellm-volume-2.1.13-Respect-LDFLAGS.patch
new file mode 100644
index 000000000000..1d711fb74946
--- /dev/null
+++ b/x11-plugins/gkrellm-volume/files/gkrellm-volume-2.1.13-Respect-LDFLAGS.patch
@@ -0,0 +1,13 @@
+diff --git a/Makefile b/Makefile
+index 7a9821d..db02cad 100644
+--- a/Makefile
++++ b/Makefile
+@@ -18,6 +18,8 @@ FLAGS = -O2 -Wall -fPIC $(GTK_CFLAGS) $(GKRELLM_INCLUDE)
+ LIBS = $(GTK_LIB)
+ LFLAGS = -shared
+
++LFLAGS += $(LDFLAGS)
++
+ OBJS = volume.o mixer.o oss_mixer.o
+
+ ifeq ($(enable_alsa),1)
diff --git a/x11-plugins/gkrellm-volume/files/gkrellm-volume-2.1.13-reenable.patch b/x11-plugins/gkrellm-volume/files/gkrellm-volume-2.1.13-reenable.patch
new file mode 100644
index 000000000000..a3e3218dc02f
--- /dev/null
+++ b/x11-plugins/gkrellm-volume/files/gkrellm-volume-2.1.13-reenable.patch
@@ -0,0 +1,14 @@
+diff --git a/volume.c b/volume.c
+index 18418d1..58708d4 100644
+--- a/volume.c
++++ b/volume.c
+@@ -74,6 +74,9 @@ static void remove_all_mixers() {
+ static Slider *add_slider(Mixer *m, int dev) {
+ Slider *result,*s;
+ if (dev < 0 || dev >= mixer_get_nr_devices(m->mixer)) return NULL;
++ for (s = m->Sliderz ; s != NULL; s = s->next)
++ if (s->dev == dev)
++ return s;
+ result = malloc(sizeof(Slider));
+ result->mixer = m->mixer;
+ result->parent = m;