summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Bracht Laumann Jespersen <t@laumann.xyz>2022-03-26 16:13:13 +0100
committerSam James <sam@gentoo.org>2022-04-21 20:54:34 +0100
commit9f5fe0f7aa0b3ddf7da451784a73dfc179fe79f6 (patch)
treef53d52911807f009cd2ff74855225ac4fe69391f /x11-plugins/gkrellm-xkb
parentx11-plugins/gkrellkam: update EAPI 6 -> 8 (diff)
downloadgentoo-9f5fe0f7aa0b3ddf7da451784a73dfc179fe79f6.tar.gz
gentoo-9f5fe0f7aa0b3ddf7da451784a73dfc179fe79f6.tar.bz2
gentoo-9f5fe0f7aa0b3ddf7da451784a73dfc179fe79f6.zip
x11-plugins/gkrellm-xkb: update EAPI 6 -> 8
Signed-off-by: Thomas Bracht Laumann Jespersen <t@laumann.xyz> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-plugins/gkrellm-xkb')
-rw-r--r--x11-plugins/gkrellm-xkb/files/gkrellm-xkb-1.05-r2-pkgconfig.patch30
-rw-r--r--x11-plugins/gkrellm-xkb/gkrellm-xkb-1.05-r2.ebuild33
2 files changed, 63 insertions, 0 deletions
diff --git a/x11-plugins/gkrellm-xkb/files/gkrellm-xkb-1.05-r2-pkgconfig.patch b/x11-plugins/gkrellm-xkb/files/gkrellm-xkb-1.05-r2-pkgconfig.patch
new file mode 100644
index 000000000000..59208c8814bb
--- /dev/null
+++ b/x11-plugins/gkrellm-xkb/files/gkrellm-xkb-1.05-r2-pkgconfig.patch
@@ -0,0 +1,30 @@
+From f4cd320421d80075c280dc23115d00ecefb8501c Mon Sep 17 00:00:00 2001
+From: Thomas Bracht Laumann Jespersen <t@laumann.xyz>
+Date: Sat, 26 Mar 2022 16:08:49 +0100
+Subject: [PATCH] pkgconfig
+
+---
+ Makefile | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 13f2dd3..a63b4ab 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,10 +1,10 @@
+
+ PREFIX ?= /usr/local
+-GTK_CONFIG = pkg-config gtk+-2.0
++PKG_CONFIG ?= pkg-config
+ PLUGIN_DIR ?= $(PREFIX)/lib/gkrellm2/plugins
+ GKRELLM_INCLUDE = -I$(PREFIX)/include
+-GTK_CFLAGS = `$(GTK_CONFIG) --cflags`
+-GTK_LIB = `$(GTK_CONFIG) --libs`
++GTK_CFLAGS = $(shell ${PKG_CONFIG} gtk+-2.0 --cflags)
++GTK_LIB = $(shell ${PKG_CONFIG} gtk+-2.0 --libs)
+ FLAGS = -fPIC $(GTK_CFLAGS) $(GKRELLM_INCLUDE)
+ LIBS = $(GTK_LIB)
+ LFLAGS = -shared
+--
+2.34.1
+
diff --git a/x11-plugins/gkrellm-xkb/gkrellm-xkb-1.05-r2.ebuild b/x11-plugins/gkrellm-xkb/gkrellm-xkb-1.05-r2.ebuild
new file mode 100644
index 000000000000..c148d04e190e
--- /dev/null
+++ b/x11-plugins/gkrellm-xkb/gkrellm-xkb-1.05-r2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gkrellm-plugin toolchain-funcs
+
+DESCRIPTION="XKB keyboard switcher for gkrellm2"
+HOMEPAGE="http://tripie.sweb.cz/gkrellm/xkb/"
+SRC_URI="http://tripie.sweb.cz/gkrellm/xkb/dist/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="app-admin/gkrellm:2[X]"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-makefile.patch
+ "${FILESDIR}"/${P}-r2-pkgconfig.patch
+)
+
+src_configure() {
+ PLUGIN_SO=( xkb$(get_modname) )
+ default
+}
+
+src_compile() {
+ tc-export PKG_CONFIG
+ emake CC="$(tc-getCC)" LDFLAGS="${LDFLAGS}"
+}