summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Bracht Laumann Jespersen <t@laumann.xyz>2022-03-24 22:20:00 +0100
committerSam James <sam@gentoo.org>2022-04-21 20:54:31 +0100
commitf1b13d98cc927be8c6540fc5076555687bdd20c1 (patch)
treecb6111300e3bd9ec87695b2d818c508f36368138 /x11-plugins/gkrellmlaunch
parentx11-plugins/gkrellm-countdown: update EAPI 6 -> 8 (diff)
downloadgentoo-f1b13d98cc927be8c6540fc5076555687bdd20c1.tar.gz
gentoo-f1b13d98cc927be8c6540fc5076555687bdd20c1.tar.bz2
gentoo-f1b13d98cc927be8c6540fc5076555687bdd20c1.zip
x11-plugins/gkrellmlaunch: update EAPI 6 -> 8
Signed-off-by: Thomas Bracht Laumann Jespersen <t@laumann.xyz> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-plugins/gkrellmlaunch')
-rw-r--r--x11-plugins/gkrellmlaunch/files/gkrellmlaunch-0.5-r1-pkgconfig.patch20
-rw-r--r--x11-plugins/gkrellmlaunch/gkrellmlaunch-0.5-r1.ebuild28
2 files changed, 48 insertions, 0 deletions
diff --git a/x11-plugins/gkrellmlaunch/files/gkrellmlaunch-0.5-r1-pkgconfig.patch b/x11-plugins/gkrellmlaunch/files/gkrellmlaunch-0.5-r1-pkgconfig.patch
new file mode 100644
index 000000000000..be77d1619c8b
--- /dev/null
+++ b/x11-plugins/gkrellmlaunch/files/gkrellmlaunch-0.5-r1-pkgconfig.patch
@@ -0,0 +1,20 @@
+--- a/Makefile
++++ b/Makefile
+@@ -1,7 +1,8 @@
+ # Sample Makefile for a GKrellM plugin
+
+-GTK_INCLUDE = `pkg-config gtk+-2.0 --cflags`
+-GTK_LIB = `pkg-config gtk+-2.0 --libs`
++PKG_CONFIG ?= pkg-config
++GTK_INCLUDE = $(shell ${PKG_CONFIG} gtk+-2.0 --cflags)
++GTK_LIB = $(shell ${PKG_CONFIG} gtk+-2.0 --libs)
+
+
+ FLAGS = -fPIC $(GTK_INCLUDE)
+@@ -25,4 +26,4 @@ gkrellmlaunch.so: $(OBJS)
+ clean:
+ rm -f *.o core *.so* *.bak *~
+
+-gkrellmlaunch.o: gkrellmlaunch.c
+\ No newline at end of file
++gkrellmlaunch.o: gkrellmlaunch.c
diff --git a/x11-plugins/gkrellmlaunch/gkrellmlaunch-0.5-r1.ebuild b/x11-plugins/gkrellmlaunch/gkrellmlaunch-0.5-r1.ebuild
new file mode 100644
index 000000000000..a3f3ab6d277b
--- /dev/null
+++ b/x11-plugins/gkrellmlaunch/gkrellmlaunch-0.5-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gkrellm-plugin toolchain-funcs
+
+DESCRIPTION="A Program-Launcher Plugin for GKrellM2"
+SRC_URI="mirror://sourceforge/gkrellmlaunch/${P}.tar.gz"
+HOMEPAGE="http://gkrellmlaunch.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+
+RDEPEND="app-admin/gkrellm:2[X]"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-makefile.patch
+ "${FILESDIR}"/${P}-r1-pkgconfig.patch
+)
+
+src_compile() {
+ tc-export PKG_CONFIG
+ emake CC="$(tc-getCC)" LDFLAGS="${LDFLAGS}"
+}