summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2017-07-26 12:53:49 +0200
committerPacho Ramos <pacho@gentoo.org>2017-07-26 13:34:24 +0200
commit38578441becce4dd26064ff7c07408c11a0423a4 (patch)
treec73a86a52532ccefe6f7843b90523e97d989f868 /x11-plugins/gkrellmoon/gkrellmoon-0.6-r2.ebuild
parentx11-plugins/gkrellm-vaiobright: Fix dependency on gkrellm[X], it also works o... (diff)
downloadgentoo-38578441becce4dd26064ff7c07408c11a0423a4.tar.gz
gentoo-38578441becce4dd26064ff7c07408c11a0423a4.tar.bz2
gentoo-38578441becce4dd26064ff7c07408c11a0423a4.zip
x11-plugins/gkrellmoon: Fix dependency on gkrellm[X]
Package-Manager: Portage-2.3.6, Repoman-2.3.2 RepoMan-Options: --force
Diffstat (limited to 'x11-plugins/gkrellmoon/gkrellmoon-0.6-r2.ebuild')
-rw-r--r--x11-plugins/gkrellmoon/gkrellmoon-0.6-r2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/x11-plugins/gkrellmoon/gkrellmoon-0.6-r2.ebuild b/x11-plugins/gkrellmoon/gkrellmoon-0.6-r2.ebuild
new file mode 100644
index 000000000000..43e7a619c6cc
--- /dev/null
+++ b/x11-plugins/gkrellmoon/gkrellmoon-0.6-r2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gkrellm-plugin toolchain-funcs
+
+IUSE=""
+DESCRIPTION="A GKrellM2 plugin of the famous wmMoonClock dockapp"
+SRC_URI="mirror://sourceforge/gkrellmoon/${P}.tar.gz"
+HOMEPAGE="http://gkrellmoon.sourceforge.net/"
+
+DEPEND="media-libs/imlib2"
+RDEPEND="${DEPEND}
+ app-admin/gkrellm[X]
+"
+
+SLOT="2"
+LICENSE="GPL-2"
+KEYWORDS="alpha amd64 ppc sparc x86"
+
+PATCHES=( "${FILESDIR}"/${P}-makefile.patch )
+
+src_prepare() {
+ default
+ sed -i -e '/^#include <stdio.h>/a#include <string.h>' CalcEphem.h
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" LDFLAGS="${LDFLAGS}"
+}