summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2018-01-03 23:34:32 +0100
committerDavid Seifert <soap@gentoo.org>2018-01-04 10:15:41 +0100
commit822e267a6a4c3554502fdf50c82961aee574ea27 (patch)
tree21961c067c430f83883a1a2e899c006a6c1bff5a /x11-plugins/gkrelltop
parentx11-plugins/gkrellmlaunch: Eclass update (diff)
downloadgentoo-822e267a6a4c3554502fdf50c82961aee574ea27.tar.gz
gentoo-822e267a6a4c3554502fdf50c82961aee574ea27.tar.bz2
gentoo-822e267a6a4c3554502fdf50c82961aee574ea27.zip
x11-plugins/gkrelltop: Eclass update
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'x11-plugins/gkrelltop')
-rw-r--r--x11-plugins/gkrelltop/files/gkrelltop-2.2.13-fix-build-system.patch41
-rw-r--r--x11-plugins/gkrelltop/gkrelltop-2.2.13-r2.ebuild33
2 files changed, 56 insertions, 18 deletions
diff --git a/x11-plugins/gkrelltop/files/gkrelltop-2.2.13-fix-build-system.patch b/x11-plugins/gkrelltop/files/gkrelltop-2.2.13-fix-build-system.patch
new file mode 100644
index 000000000000..9eaa9cc3d4e8
--- /dev/null
+++ b/x11-plugins/gkrelltop/files/gkrelltop-2.2.13-fix-build-system.patch
@@ -0,0 +1,41 @@
+--- a/Makefile
++++ b/Makefile
+@@ -45,11 +45,10 @@
+ # Parameters for gkrellm version 2.*
+ CFLAGS2 = -g -D$(OSFLAG) -DGKRELLM2 -fPIC -Wall `pkg-config gtk+-2.0 --cflags`
+ LIBS =
+-CC=/usr/bin/gcc $(CFLAGS2)
++CC += $(CFLAGS) $(CFLAGS2)
+
+ else
+ # Parameters for gkrellm version 1.*
+-CC=/usr/bin/cc
+ CFLAGS = -D$(OSFLAG) -Wall -fPIC `gtk-config --cflags` `imlib-config --cflags-gdk`
+ LIBS=
+
+@@ -78,7 +77,7 @@
+ ifeq ($(INSTALLDIRD),)
+ INSTALLDIRD=$(HOME)/.gkrellm2/plugins-gkrellmd
+ endif
+-CCD=/usr/bin/gcc $(CFLAGSD)
++CCD = $(CC) $(CFLAGS) $(CFLAGSD)
+ OBJD = gkrelltopd.o top_three.o
+
+ DUMMY_VAR := $(shell ./configure $(CONFIGURE_ARGS))
+@@ -100,14 +99,14 @@
+ warn: ; $(WARN)
+
+ $(GKRELLTOP): $(OBJ) warn
+- $(CC) -shared $(OBJ) -o $(GKRELLTOP)
++ $(CC) $(LDFLAGS) -shared $(OBJ) -o $(GKRELLTOP)
+
+ # Compile gkrelltopd.so server plugin
+ server: $(GKRELLTOPD) warn
+ @echo ""
+
+ $(GKRELLTOPD): $(OBJD)
+- $(CCD) $(LIBSD) -shared $(OBJD) -o $(GKRELLTOPD)
++ $(CCD) $(LIBSD) $(LDFLAGS) -shared $(OBJD) -o $(GKRELLTOPD)
+
+ gkrelltop.o: gkrelltop.c
+ $(CC) -c gkrelltop.c -o gkrelltop.o
diff --git a/x11-plugins/gkrelltop/gkrelltop-2.2.13-r2.ebuild b/x11-plugins/gkrelltop/gkrelltop-2.2.13-r2.ebuild
index 4e6349415d03..059b7d824e5b 100644
--- a/x11-plugins/gkrelltop/gkrelltop-2.2.13-r2.ebuild
+++ b/x11-plugins/gkrelltop/gkrelltop-2.2.13-r2.ebuild
@@ -1,41 +1,38 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
+
inherit gkrellm-plugin toolchain-funcs
DESCRIPTION="a GKrellM2 plugin which displays the top three processes"
SRC_URI="mirror://sourceforge/${PN}/${PN}_${PV}.orig.tar.gz"
HOMEPAGE="https://sourceforge.net/projects/gkrelltop"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="amd64 ppc x86"
IUSE="X"
-PLUGIN_SERVER_SO=gkrelltopd.so
-PLUGIN_SO=gkrelltop.so
-
-S="${WORKDIR}/${P}.orig"
-
RDEPEND="
- app-admin/gkrellm[X]
+ app-admin/gkrellm:2[X]
dev-libs/glib:2
- x11-libs/gtk+:2
-"
+ x11-libs/gtk+:2"
DEPEND="${RDEPEND}"
-src_prepare() {
- sed -i \
- -e "s:/usr/bin/gcc:$(tc-getCC) \$(CFLAGS):" \
- -e 's/-shared/$(LDFLAGS) &/' \
- Makefile || die
- default
+S=${WORKDIR}/${P}.orig
+PATCHES=( "${FILESDIR}"/${PN}-2.2.13-fix-build-system.patch )
+
+PLUGIN_SERVER_SO=( gkrelltopd$(get_modname) )
+PLUGIN_SO=( gkrelltop$(get_modname) )
+
+src_configure() {
+ tc-export CC
}
src_compile() {
- use X || TARGET="server"
- emake ${TARGET}
+ use X || local target="server"
+ emake ${target}
}
pkg_postinst() {