summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-plugins/matchbox-applet-startup-monitor
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-plugins/matchbox-applet-startup-monitor')
-rw-r--r--x11-plugins/matchbox-applet-startup-monitor/Manifest1
-rw-r--r--x11-plugins/matchbox-applet-startup-monitor/files/matchbox-applet-startup-monitor-0.1-false-true-fix.patch18
-rw-r--r--x11-plugins/matchbox-applet-startup-monitor/matchbox-applet-startup-monitor-0.1.ebuild44
-rw-r--r--x11-plugins/matchbox-applet-startup-monitor/metadata.xml5
4 files changed, 68 insertions, 0 deletions
diff --git a/x11-plugins/matchbox-applet-startup-monitor/Manifest b/x11-plugins/matchbox-applet-startup-monitor/Manifest
new file mode 100644
index 000000000000..6114ba260c05
--- /dev/null
+++ b/x11-plugins/matchbox-applet-startup-monitor/Manifest
@@ -0,0 +1 @@
+DIST mb-applet-startup-monitor-0.1.tar.bz2 206232 SHA256 d0f1ba8275f688e7619c8a570e2a99f889e54efff8cb79d348827e2cb753d864
diff --git a/x11-plugins/matchbox-applet-startup-monitor/files/matchbox-applet-startup-monitor-0.1-false-true-fix.patch b/x11-plugins/matchbox-applet-startup-monitor/files/matchbox-applet-startup-monitor-0.1-false-true-fix.patch
new file mode 100644
index 000000000000..1c8530497313
--- /dev/null
+++ b/x11-plugins/matchbox-applet-startup-monitor/files/matchbox-applet-startup-monitor-0.1-false-true-fix.patch
@@ -0,0 +1,18 @@
+diff -Naurp mb-applet-startup-monitor-0.1.orig/mbmonitor.c mb-applet-startup-monitor-0.1/mbmonitor.c
+--- mb-applet-startup-monitor-0.1.orig/mbmonitor.c 2004-12-21 11:00:24.000000000 -0500
++++ mb-applet-startup-monitor-0.1/mbmonitor.c 2006-06-23 12:33:38.000000000 -0400
+@@ -39,6 +39,14 @@
+
+ #include <libmb/mb.h>
+
++/* libmb inherits FALSE/TRUE definitions only if compiled with jpeg support. */
++#ifndef FALSE
++#define FALSE 0
++#endif
++#ifndef TRUE
++#define TRUE 1
++#endif
++
+ #define TIMEOUT 20
+ #define POLLTIME 10
+ #define HOURGLASS_N_FRAMES 8
diff --git a/x11-plugins/matchbox-applet-startup-monitor/matchbox-applet-startup-monitor-0.1.ebuild b/x11-plugins/matchbox-applet-startup-monitor/matchbox-applet-startup-monitor-0.1.ebuild
new file mode 100644
index 000000000000..ad484951c933
--- /dev/null
+++ b/x11-plugins/matchbox-applet-startup-monitor/matchbox-applet-startup-monitor-0.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils versionator
+
+MY_PN=${PN/matchbox/mb}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Startup notification matchbox panel tray app"
+HOMEPAGE="http://matchbox-project.org/"
+SRC_URI="http://matchbox-project.org/sources/${MY_PN}/$(get_version_component_range 1-2)/${MY_P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="amd64 ~arm ~hppa ppc x86"
+IUSE=""
+
+DEPEND=">=x11-libs/libmatchbox-1.5
+ x11-libs/startup-notification"
+
+RDEPEND="${DEPEND}
+ x11-wm/matchbox-panel"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack () {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-false-true-fix.patch
+}
+
+src_compile() {
+ econf || die "Configuration failed"
+
+ emake || die "Compilation failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "Installation failed"
+
+ dodoc AUTHORS ChangeLog INSTALL NEWS README
+}
diff --git a/x11-plugins/matchbox-applet-startup-monitor/metadata.xml b/x11-plugins/matchbox-applet-startup-monitor/metadata.xml
new file mode 100644
index 000000000000..6a17403e0ad0
--- /dev/null
+++ b/x11-plugins/matchbox-applet-startup-monitor/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gpe</herd>
+</pkgmetadata>