summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-plugins/pidgin-libnotify
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-plugins/pidgin-libnotify')
-rw-r--r--x11-plugins/pidgin-libnotify/Manifest2
-rw-r--r--x11-plugins/pidgin-libnotify/files/pidgin-libnotify-0.14-libnotify-0.7.patch18
-rw-r--r--x11-plugins/pidgin-libnotify/files/pidgin-libnotify-showbutton.patch10
-rw-r--r--x11-plugins/pidgin-libnotify/metadata.xml8
-rw-r--r--x11-plugins/pidgin-libnotify/pidgin-libnotify-0.14-r1.ebuild41
5 files changed, 79 insertions, 0 deletions
diff --git a/x11-plugins/pidgin-libnotify/Manifest b/x11-plugins/pidgin-libnotify/Manifest
new file mode 100644
index 000000000000..5e3fb92b9eb3
--- /dev/null
+++ b/x11-plugins/pidgin-libnotify/Manifest
@@ -0,0 +1,2 @@
+DIST pidgin-libnotify-0.14.tar.gz 316365 SHA256 74f4a9f20e0a483df39974178f1f2380786176189512bcd438e4ada280ec3abe SHA512 2ff6b2bad74cb2fd9a3de94c06a2261fa07938bc1971baa578b9a9ae120175943592bf773ec5f00857c5ea35771a7fd1943299521626ce49f410cfd70ea2b399 WHIRLPOOL 05b98c55e4feb3d314f8203e6fb30ae58aaa1adb39d34c2895a4c7b1fd8393eab9f071f6c0c80696e4113407435ff2adb683054057ea09eef1281480826365fe
+DIST pidgin-libnotify_0.14-4.debian.tar.gz 4722 SHA256 63cad8b5065a84002c87f1056f5d2198bcc16c7947c7b5125a859c4deec5afcc SHA512 a95aab2e29b658650321ab794561fe085c619638c251d8555dfc6f79ddf298d4893671f43827ce742ebc5aa594324aeff12a57c51f3ca0a0454590195c760530 WHIRLPOOL 265a2df9236e69c8917fc31b0a4c39e4501478858249b77dbe8fe26b0ca12d020fe9f20ac99d87fd184a258dbd5e9dd6466406b66a6d4941967c8695a74bbde3
diff --git a/x11-plugins/pidgin-libnotify/files/pidgin-libnotify-0.14-libnotify-0.7.patch b/x11-plugins/pidgin-libnotify/files/pidgin-libnotify-0.14-libnotify-0.7.patch
new file mode 100644
index 000000000000..40e6c02b8152
--- /dev/null
+++ b/x11-plugins/pidgin-libnotify/files/pidgin-libnotify-0.14-libnotify-0.7.patch
@@ -0,0 +1,18 @@
+--- src/pidgin-libnotify.c
++++ src/pidgin-libnotify.c
+@@ -286,7 +286,15 @@
+ g_free (tr_body);
+ return;
+ }
++#ifdef NOTIFY_CHECK_VERSION
++#if NOTIFY_CHECK_VERSION (0, 7, 0)
++ notification = notify_notification_new (title, tr_body, NULL);
++#else
+ notification = notify_notification_new (title, tr_body, NULL, NULL);
++#endif
++#else
++ notification = notify_notification_new (title, tr_body, NULL, NULL);
++#endif
+ purple_debug_info (PLUGIN_ID, "notify(), new: "
+ "title: '%s', body: '%s', buddy: '%s'\n",
+ title, tr_body, best_name (buddy));
diff --git a/x11-plugins/pidgin-libnotify/files/pidgin-libnotify-showbutton.patch b/x11-plugins/pidgin-libnotify/files/pidgin-libnotify-showbutton.patch
new file mode 100644
index 000000000000..1f84e6025557
--- /dev/null
+++ b/x11-plugins/pidgin-libnotify/files/pidgin-libnotify-showbutton.patch
@@ -0,0 +1,10 @@
+--- src/pidgin-libnotify.c.orig 2007-10-01 20:52:38.000000000 +1000
++++ src/pidgin-libnotify.c 2007-10-01 20:53:20.000000000 +1000
+@@ -307,6 +307,7 @@
+ g_hash_table_insert (buddy_hash, contact, notification);
+
+ g_object_set_data (G_OBJECT(notification), "contact", contact);
++ g_object_set_data (G_OBJECT(notification), "buddy", buddy);
+
+ g_signal_connect (notification, "closed", G_CALLBACK(closed_cb), NULL);
+
diff --git a/x11-plugins/pidgin-libnotify/metadata.xml b/x11-plugins/pidgin-libnotify/metadata.xml
new file mode 100644
index 000000000000..a071398a197f
--- /dev/null
+++ b/x11-plugins/pidgin-libnotify/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-im</herd>
+ <upstream>
+ <remote-id type="sourceforge">gaim-libnotify</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/x11-plugins/pidgin-libnotify/pidgin-libnotify-0.14-r1.ebuild b/x11-plugins/pidgin-libnotify/pidgin-libnotify-0.14-r1.ebuild
new file mode 100644
index 000000000000..0559f02d2071
--- /dev/null
+++ b/x11-plugins/pidgin-libnotify/pidgin-libnotify-0.14-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit eutils
+
+DESCRIPTION="pidgin-libnotify provides popups for pidgin via a libnotify interface"
+HOMEPAGE="http://gaim-libnotify.sourceforge.net/"
+SRC_URI="mirror://sourceforge/gaim-libnotify/${P}.tar.gz
+ mirror://debian/pool/main/p/${PN}/${PN}_${PV}-4.debian.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="nls debug"
+
+RDEPEND=">=x11-libs/libnotify-0.3.2
+ net-im/pidgin[gtk]
+ x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ EPATCH_FORCE=yes EPATCH_SUFFIX=diff epatch "${WORKDIR}"/debian/patches
+ epatch "${FILESDIR}"/${P}-libnotify-0.7.patch
+ sed -i -e '/CFLAGS/s:-g3::' configure || die
+}
+
+src_configure() {
+ econf \
+ --disable-static \
+ $(use_enable debug) \
+ $(use_enable nls)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ find "${D}" -name '*.la' -exec rm -f {} +
+ dodoc AUTHORS ChangeLog NEWS README TODO VERSION || die
+}