summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-08-10 10:56:23 -0700
committerMatt Turner <mattst88@gentoo.org>2020-08-10 10:56:45 -0700
commit42d878d3ce708f2f77f4258bb65e8dfa83aa91e2 (patch)
treeb4fc07df2edfb5c1cd15b34a40ffa140284497fc /x11-plugins/pidgin-opensteamworks
parentmedia-sound/cadence: removed obsolete 0.9.0-r4 (diff)
downloadgentoo-42d878d3ce708f2f77f4258bb65e8dfa83aa91e2.tar.gz
gentoo-42d878d3ce708f2f77f4258bb65e8dfa83aa91e2.tar.bz2
gentoo-42d878d3ce708f2f77f4258bb65e8dfa83aa91e2.zip
x11-plugins/pidgin-opensteamworks: Drop old versions
Closes: https://bugs.gentoo.org/713040 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-plugins/pidgin-opensteamworks')
-rw-r--r--x11-plugins/pidgin-opensteamworks/Manifest1
-rw-r--r--x11-plugins/pidgin-opensteamworks/files/pidgin-opensteamworks-1.3-Makefile33
-rw-r--r--x11-plugins/pidgin-opensteamworks/pidgin-opensteamworks-1.6.1.ebuild53
3 files changed, 0 insertions, 87 deletions
diff --git a/x11-plugins/pidgin-opensteamworks/Manifest b/x11-plugins/pidgin-opensteamworks/Manifest
index f1c6af4cf884..7c173ac6b6bf 100644
--- a/x11-plugins/pidgin-opensteamworks/Manifest
+++ b/x11-plugins/pidgin-opensteamworks/Manifest
@@ -1,2 +1 @@
-DIST pidgin-opensteamworks-1.6.1.tar.gz 750495 BLAKE2B 890e1765eda10c31e927be320a8bf8af0da4c9e01b8cea31810c0ff7a0c27d1a8f54b213b323132a6c1087dd853937a0b5cce93eeef308412a505cd1696eb5f4 SHA512 9f025538460dda01d769501326cf7ac597e069bdef3437eea89f392bede7e620e854a8c0b0659315a0834c8f2f60a38680f1f1bdccdb65d3b13f64f7981ee55b
DIST pidgin-opensteamworks-1.7.tar.gz 236181 BLAKE2B 738285b566558ecbdbaf4960e2cead6bb57721dec901e656c6a78f3e5e16aecfa0f88045dd8fe78decef013866dcf255b82873021fb4ac9c484ed3bed8d0c655 SHA512 6369d8fb49fca3c8ad760d379c413da0be8bf58cbfdc5a4bb41ea6d803493110da8b0e1e3743c81b5068799b3a0ba6f57a90ba6208a5b112eb58434d134b1ba6
diff --git a/x11-plugins/pidgin-opensteamworks/files/pidgin-opensteamworks-1.3-Makefile b/x11-plugins/pidgin-opensteamworks/files/pidgin-opensteamworks-1.3-Makefile
deleted file mode 100644
index a71ece054234..000000000000
--- a/x11-plugins/pidgin-opensteamworks/files/pidgin-opensteamworks-1.3-Makefile
+++ /dev/null
@@ -1,33 +0,0 @@
-CC ?= gcc
-PKG_CONFIG ?= pkg-config
-INSTALL = install
-INSTALL_PROGRAM = $(INSTALL) -Dm755
-
-PLUGINDIR ?= $(shell $(PKG_CONFIG) --variable=plugindir purple)
-
-CFLAGS ?= -O2 -pipe
-CFLAGS += -Wall -fPIC
-LDFLAGS += -shared
-CPPFLAGS += $(shell $(PKG_CONFIG) --cflags glib-2.0 json-glib-1.0 purple nss gnome-keyring-1)
-LIBS += $(shell $(PKG_CONFIG) --libs glib-2.0 json-glib-1.0 purple nss)
-
-TARGET = libsteam.so
-
-OBJS = libsteam.o steam_connection.o
-
-%.o: %.c %.h
- $(CC) $(CFLAGS) $(CPPFLAGS) -c $*.c
-
-$(TARGET): $(OBJS)
- $(CC) $(LDFLAGS) $(CFLAGS) -o $@ $(OBJS) $(LIBS)
-
-install: $(TARGET)
- $(INSTALL_PROGRAM) $(TARGET) "$(DESTDIR)$(PLUGINDIR)/$(TARGET)"
-
-uninstall:
- rm -f "$(DESTDIR)$(PLUGINDIR)/$(TARGET)"
-
-clean:
- rm -f $(OBJS) $(TARGET)
-
-.PHONY: uninstall clean
diff --git a/x11-plugins/pidgin-opensteamworks/pidgin-opensteamworks-1.6.1.ebuild b/x11-plugins/pidgin-opensteamworks/pidgin-opensteamworks-1.6.1.ebuild
deleted file mode 100644
index 4cbbdc43091c..000000000000
--- a/x11-plugins/pidgin-opensteamworks/pidgin-opensteamworks-1.6.1.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit toolchain-funcs
-
-DESCRIPTION="Steam protocol plugin for pidgin"
-HOMEPAGE="https://github.com/eionrobb/pidgin-opensteamworks"
-SRC_URI="https://github.com/EionRobb/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 ~ppc x86"
-IUSE=""
-
-RDEPEND="dev-libs/glib:2
- dev-libs/json-glib
- dev-libs/nss
- gnome-base/libgnome-keyring
- net-im/pidgin"
-DEPEND="${RDEPEND}
- app-arch/unzip
- virtual/pkgconfig"
-
-S=${WORKDIR}
-
-pkg_setup() {
- if [[ ${MERGE_TYPE} != binary ]]; then
- tc-export CC PKG_CONFIG
- fi
-}
-
-src_prepare() {
- # see https://code.google.com/p/pidgin-opensteamworks/issues/detail?id=31
- cp "${FILESDIR}"/${PN}-1.3-Makefile "${S}"/${P}/steam-mobile/Makefile || die
- unzip "${S}"/${P}/steam-mobile/releases/icons.zip || die
-}
-
-src_compile() {
- pushd ${P}/steam-mobile || die
- default
- popd || die
-}
-
-src_install() {
- pushd ${P}/steam-mobile || die
- default
- popd || die
- insinto /usr/share/pixmaps/pidgin/protocols
- doins -r "${WORKDIR}"/{16,48}
- dodoc ${P}/README.md
-}