summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Whyman <thev00d00@gentoo.org>2018-10-25 19:39:58 +0100
committerIan Whyman <thev00d00@gentoo.org>2018-10-25 19:39:58 +0100
commit4946108d199b48872c6baf67d592827935c3468d (patch)
tree3f15f4c04b3932980fd56e61127692e615c9975c /x11-plugins/pidgin-sipe
parentmedia-video/handbrake: bump (diff)
downloadgentoo-4946108d199b48872c6baf67d592827935c3468d.tar.gz
gentoo-4946108d199b48872c6baf67d592827935c3468d.tar.bz2
gentoo-4946108d199b48872c6baf67d592827935c3468d.zip
x11-plugins/pidgin-sipe: bump
Signed-off-by: Ian Whyman <thev00d00@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'x11-plugins/pidgin-sipe')
-rw-r--r--x11-plugins/pidgin-sipe/Manifest1
-rw-r--r--x11-plugins/pidgin-sipe/pidgin-sipe-1.23.3.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/x11-plugins/pidgin-sipe/Manifest b/x11-plugins/pidgin-sipe/Manifest
index 9111ff5322e4..e24c3edcd4b7 100644
--- a/x11-plugins/pidgin-sipe/Manifest
+++ b/x11-plugins/pidgin-sipe/Manifest
@@ -1,3 +1,4 @@
DIST pidgin-sipe-1.22.0.tar.gz 1255851 BLAKE2B 442206854bc420f8a93a34246f28a923adc83c08a9c113d871f920799e2b33505a14b4181d1b20aa65e03c6d6483b01be22e66ed4496ea8571247bfc560d2a97 SHA512 4135bbf526659663b0b053592d889588574ed2a1bc9346e6ba62960203409e2604552ffb02ed32e2b4bb46c4f40f62089302b301344b9f7b45657e64a585f7ed
DIST pidgin-sipe-1.23.0.tar.gz 1296050 BLAKE2B 1c69587ab6407b6c83dda349ab9a5ad61e3e1d8936b58d7edd71cbead3f8573ab60f7e95866968ec55163a533077be268d6166354d9d22cd2110e6b2ae1708c0 SHA512 8ed0c353e83707b99059791b97568d874634eb1d5ec1a43031864cc8469dc859e7485eb617fe5e23960c091fb15334a903452827ef8a650ed4d677f3a2222cef
DIST pidgin-sipe-1.23.2.tar.gz 1297900 BLAKE2B 2e37fc883c04ae9cb3ed562e932f0d207c449f67521c65a64bd52a580386fb822d10814bb7fda7cb0f6a67ae949b428db0b3c160f113c279b2e8440360af14ba SHA512 150dd41577c571442c664d91b55cff461ce2bd8dfdca6e8c8dffd27ee22c35393031ddcc7e070409ed5206f8cd0f17246f70d9ebfb6c868503a90be989ac34e6
+DIST pidgin-sipe-1.23.3.tar.gz 1298459 BLAKE2B e15ad7658771fc0d7f5320f6b145e67a6f33603dfe49dd83edbf42fd2e57f117f4cdac53c6b6dba401266ae6c2593bb6078a604c164aa365aa94aa64eb94f1c7 SHA512 3c7481e02f9541818a980df31d135c3eefd8f1e921dcb6cfe3d1ce194b1591531db2c23364b545a912eb3818af207ffc0a19d3310d495db503de954f0547ea31
diff --git a/x11-plugins/pidgin-sipe/pidgin-sipe-1.23.3.ebuild b/x11-plugins/pidgin-sipe/pidgin-sipe-1.23.3.ebuild
new file mode 100644
index 000000000000..dfeeb6f126f2
--- /dev/null
+++ b/x11-plugins/pidgin-sipe/pidgin-sipe-1.23.3.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Pidgin Plug-in SIPE (Sip Exchange Protocol)"
+HOMEPAGE="http://sipe.sourceforge.net/"
+SRC_URI="mirror://sourceforge/sipe/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="dbus debug kerberos ocs2005-message-hack openssl telepathy voice"
+
+RDEPEND="
+ dev-libs/gmime:2.6
+ dev-libs/libxml2
+ openssl? ( dev-libs/openssl:= )
+ !openssl? ( dev-libs/nss )
+ kerberos? ( virtual/krb5 )
+ voice? (
+ >=dev-libs/glib-2.28.0
+ >=net-libs/libnice-0.1.0
+ media-libs/gstreamer:1.0
+ net-libs/farstream:0.2
+ )
+ !voice? (
+ >=dev-libs/glib-2.12.0:2
+ )
+ net-im/pidgin[dbus?]
+ telepathy? (
+ >=sys-apps/dbus-1.1.0
+ >=dev-libs/dbus-glib-0.61
+ >=dev-libs/glib-2.28:2
+ >=net-libs/telepathy-glib-0.18.0
+ )
+"
+
+DEPEND="dev-util/intltool
+ virtual/pkgconfig
+ ${RDEPEND}
+"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-purple \
+ --disable-quality-check \
+ $(use_enable telepathy) \
+ $(use_enable debug) \
+ $(use_enable ocs2005-message-hack) \
+ $(use_with dbus) \
+ $(use_with kerberos krb5) \
+ $(use_with voice vv) \
+ $(use_enable !openssl nss) \
+ $(use_enable openssl)
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+ dodoc AUTHORS ChangeLog NEWS TODO README
+}