summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conrad@kostecki.com>2018-06-19 20:26:48 +0200
committerMichał Górny <mgorny@gentoo.org>2018-06-20 10:21:25 +0200
commita447990a612bc157f3efddeb248c11dbe4446ba0 (patch)
treedc347dbded6f5a551643cc75636231e68aa3d061 /x11-plugins/pidgin-telegram
parentdev-libs/nmeap: New package (diff)
downloadgentoo-a447990a612bc157f3efddeb248c11dbe4446ba0.tar.gz
gentoo-a447990a612bc157f3efddeb248c11dbe4446ba0.tar.bz2
gentoo-a447990a612bc157f3efddeb248c11dbe4446ba0.zip
x11-plugins/pidgin-telegram: New package
Closes: https://bugs.gentoo.org/529908 Closes: https://github.com/gentoo/gentoo/pull/7777 Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'x11-plugins/pidgin-telegram')
-rw-r--r--x11-plugins/pidgin-telegram/Manifest1
-rw-r--r--x11-plugins/pidgin-telegram/metadata.xml20
-rw-r--r--x11-plugins/pidgin-telegram/pidgin-telegram-1.3.1.ebuild44
3 files changed, 65 insertions, 0 deletions
diff --git a/x11-plugins/pidgin-telegram/Manifest b/x11-plugins/pidgin-telegram/Manifest
new file mode 100644
index 000000000000..eb67b1be45ec
--- /dev/null
+++ b/x11-plugins/pidgin-telegram/Manifest
@@ -0,0 +1 @@
+DIST telegram-purple_1.3.1.orig.tar.gz 509083 BLAKE2B 5842fac81fa1cd9d2681fe5ac790f0be227dadc49d2031a1682da74f62ae163c7ee9d7bb8f421a974bb0d3ea135b1d44983c976b1afbb81758a3953e89f9c68a SHA512 3d088ea8b77aeba1d7f26dcd3223420bcd50372d610368b8786eca0cbdb0a11bcc2d93f7948348c5e0305479703f74e5b5ad8e06e782e2df119cfd73a4e4a63e
diff --git a/x11-plugins/pidgin-telegram/metadata.xml b/x11-plugins/pidgin-telegram/metadata.xml
new file mode 100644
index 000000000000..c8fb36cb1a77
--- /dev/null
+++ b/x11-plugins/pidgin-telegram/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>ck+gentoo@bl4ckb0x.de</email>
+ <name>Conrad Kostecki</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ This plugin adds support for the Telegram messenger protocol,
+ which can be used directly in net-im/pidgin.
+ Telegram is a cloud-based instant messaging and voice over IP service.
+ </longdescription>
+ <use>
+ <flag name="gcrypt">Use dev-libs/libgcrypt instead of dev-libs/openssl.</flag>
+ </use>
+</pkgmetadata>
diff --git a/x11-plugins/pidgin-telegram/pidgin-telegram-1.3.1.ebuild b/x11-plugins/pidgin-telegram/pidgin-telegram-1.3.1.ebuild
new file mode 100644
index 000000000000..90999385581b
--- /dev/null
+++ b/x11-plugins/pidgin-telegram/pidgin-telegram-1.3.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="A libpurple protocol plugin that adds support for the Telegram messenger"
+HOMEPAGE="https://github.com/majn/telegram-purple"
+SRC_URI="https://github.com/majn/telegram-purple/releases/download/v${PV}/telegram-purple_${PV}.orig.tar.gz"
+
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="gcrypt +nls +webp"
+
+RDEPEND="net-im/pidgin
+ sys-libs/zlib:=
+ gcrypt? ( dev-libs/libgcrypt:0= )
+ !gcrypt? ( dev-libs/openssl:0= )
+ nls? ( sys-devel/gettext )
+ webp? ( media-libs/libwebp:= )"
+
+DEPEND="virtual/pkgconfig
+ ${RDEPEND}"
+
+S="${WORKDIR}/telegram-purple"
+
+DOCS=( "AUTHORS" "CHANGELOG.md" "HACKING.md" "HACKING.BUILD.md" "README.md" )
+
+src_prepare() {
+ default
+
+ # Remove '-Werror' to make it compile
+ find -name 'Makefile*' -exec sed -i -e 's/-Werror //' {} + || die
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable gcrypt)
+ $(use_enable nls translation)
+ $(use_enable webp libwebp)
+ )
+
+ econf "${myeconfargs[@]}"
+}