summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-plugins/purple-plugin_pack/purple-plugin_pack-2.7.0-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-plugins/purple-plugin_pack/purple-plugin_pack-2.7.0-r1.ebuild')
-rw-r--r--x11-plugins/purple-plugin_pack/purple-plugin_pack-2.7.0-r1.ebuild75
1 files changed, 75 insertions, 0 deletions
diff --git a/x11-plugins/purple-plugin_pack/purple-plugin_pack-2.7.0-r1.ebuild b/x11-plugins/purple-plugin_pack/purple-plugin_pack-2.7.0-r1.ebuild
new file mode 100644
index 000000000000..f366ad7bac50
--- /dev/null
+++ b/x11-plugins/purple-plugin_pack/purple-plugin_pack-2.7.0-r1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+inherit eutils python-any-r1
+
+MY_PN=${PN/_/-}
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="A package with many different plugins for pidgin and libpurple"
+HOMEPAGE="https://bitbucket.org/rekkanoryo/purple-plugin-pack/"
+SRC_URI="https://bitbucket.org/rekkanoryo/${MY_PN}/downloads/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 hppa ppc x86"
+IUSE="debug gtk ncurses spell talkfilters"
+
+RDEPEND="dev-libs/json-glib
+ net-im/pidgin[gtk?,ncurses?]
+ talkfilters? ( app-text/talkfilters )
+ spell? ( app-text/gtkspell:2 )"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ sed -e '/CFLAGS=/{s| -g3||}' -i configure || die
+}
+
+list_plugins_dep() {
+ local dependency=${1}
+ grep -EH "depends.*$dependency" */plugins.cfg | sed 's:/.*::'
+}
+
+src_configure() {
+ local plugins=""
+
+ # list all plugins, then pull DISABLED_PLUGINS with the ones we don't need
+ plugins="$(${EPYTHON} plugin_pack.py -d dist_dirs)"
+ einfo "List of all possible plugins:"
+ einfo "${plugins}"
+
+ eval DISABLED_PLUGINS="\$${PN//[^a-z]/_}_DISABLED_PLUGINS"
+ # disable known broken plugins
+ DISABLED_PLUGINS+=" schedule findip"
+ use gtk || DISABLED_PLUGINS+=" $(list_plugins_dep pidgin)"
+ use ncurses || DISABLED_PLUGINS+=" $(list_plugins_dep finch)"
+ use spell || DISABLED_PLUGINS+=" $(list_plugins_dep gtkspell)"
+ use talkfilters || DISABLED_PLUGINS+=" $(list_plugins_dep talkfiltersbin)"
+
+ for plug in ${DISABLED_PLUGINS}; do
+ plugins="${plugins//${plug}}"
+ done
+
+ plugins="$(echo ${plugins} | sed 's:[ \t]\+:,:g;s:,$::;s:^,::')"
+
+ econf \
+ --with-plugins="${plugins}" \
+ $(use_enable debug)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog NEWS README VERSION
+}
+
+pkg_preinst() {
+ elog "Note: if you want to disable some plugins in pack, define"
+ elog "${PN//[^a-z]/_}_DISABLED_PLUGINS with a list of plugins to"
+ elog "skip during install (for list see einfo in build output)."
+}