summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-plugins/wmDownload
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-plugins/wmDownload')
-rw-r--r--x11-plugins/wmDownload/Manifest1
-rw-r--r--x11-plugins/wmDownload/files/wmDownload-0.1.2a-makefile.patch28
-rw-r--r--x11-plugins/wmDownload/metadata.xml12
-rw-r--r--x11-plugins/wmDownload/wmDownload-0.1.2a-r1.ebuild36
4 files changed, 77 insertions, 0 deletions
diff --git a/x11-plugins/wmDownload/Manifest b/x11-plugins/wmDownload/Manifest
new file mode 100644
index 000000000000..92ffc8c4dc21
--- /dev/null
+++ b/x11-plugins/wmDownload/Manifest
@@ -0,0 +1 @@
+DIST wmDownload-0.1.2a.tar.gz 11449 SHA256 77178290b9ac6e6b590280c8a9c6494fbe7853fff453e37651dd2ef9915c7213
diff --git a/x11-plugins/wmDownload/files/wmDownload-0.1.2a-makefile.patch b/x11-plugins/wmDownload/files/wmDownload-0.1.2a-makefile.patch
new file mode 100644
index 000000000000..7dfdabc9cd76
--- /dev/null
+++ b/x11-plugins/wmDownload/files/wmDownload-0.1.2a-makefile.patch
@@ -0,0 +1,28 @@
+--- Makefile.orig 2000-04-14 15:39:52.000000000 +0200
++++ Makefile 2008-01-27 23:07:51.000000000 +0100
+@@ -1,17 +1,17 @@
+-CC = gcc
+-CFLAGS = -O2 -Wall -fomit-frame-pointer -s
+-INCDIR = -I/usr/X11R6/include/X11
+-DESTDIR= /usr/bin
+-LIBDIR = -L/usr/X11R6/lib
++CC ?= gcc
++CFLAGS += -Wall
++INCDIR = -I/usr/include/X11
++PREFIX = /usr
++LIBDIR ?= /usr/lib
+ LIBS = -ldockapp -lX11 -lXext -lXpm
+ OBJS = wmDownload.o
+
+ wmDownload: $(OBJS)
+- $(CC) $(CFLAGS) $(OBJS) -o wmDownload $(INCDIR) $(LIBDIR) $(LIBS)
++ $(CC) $(CFLAGS) $(OBJS) -o wmDownload $(INCDIR) -L$(LIBDIR) $(LDFLAGS) $(LIBS)
+
+ install: wmDownload
+- strip wmDownload
+- install -s wmDownload $(DESTDIR)
++ install -d $(DESTDIR)$(PREFIX)/bin
++ install -m 0755 wmDownload $(DESTDIR)$(PREFIX)/bin
+
+ uninstall:
+ rm -f $(DESTDIR)/wmDownload
diff --git a/x11-plugins/wmDownload/metadata.xml b/x11-plugins/wmDownload/metadata.xml
new file mode 100644
index 000000000000..14f71203f8c2
--- /dev/null
+++ b/x11-plugins/wmDownload/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-dock</herd>
+ <longdescription>
+ wmDownload is a small WindowMaker dockapp that sits there and displays how much
+ data you've recieved on each eth and ppp device installed on your machine.
+ </longdescription>
+ <upstream>
+ <remote-id type="sourceforge">wmdownload</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/x11-plugins/wmDownload/wmDownload-0.1.2a-r1.ebuild b/x11-plugins/wmDownload/wmDownload-0.1.2a-r1.ebuild
new file mode 100644
index 000000000000..0b04d0aa0a1c
--- /dev/null
+++ b/x11-plugins/wmDownload/wmDownload-0.1.2a-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="dockapp that displays how much data you've received on each eth and ppp device"
+SRC_URI="mirror://sourceforge/wmdownload/${P}.tar.gz"
+HOMEPAGE="http://wmdownload.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc sparc x86"
+IUSE=""
+
+DEPEND="x11-libs/libdockapp
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+
+S="${WORKDIR}/${PN}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-makefile.patch
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" LIBDIR="/usr/$(get_libdir)" || die "compile failed"
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "install failed"
+ dodoc CHANGELOG CREDITS HINTS README TODO
+}