summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-plugins/wmSpaceWeather/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-plugins/wmSpaceWeather/files')
-rw-r--r--x11-plugins/wmSpaceWeather/files/wmSpaceWeather-1.04_p19-gentoo.patch61
-rw-r--r--x11-plugins/wmSpaceWeather/files/wmSpaceWeather-1.04_p19-getkp.patch27
2 files changed, 88 insertions, 0 deletions
diff --git a/x11-plugins/wmSpaceWeather/files/wmSpaceWeather-1.04_p19-gentoo.patch b/x11-plugins/wmSpaceWeather/files/wmSpaceWeather-1.04_p19-gentoo.patch
new file mode 100644
index 000000000000..29cb5f984f13
--- /dev/null
+++ b/x11-plugins/wmSpaceWeather/files/wmSpaceWeather-1.04_p19-gentoo.patch
@@ -0,0 +1,61 @@
+--- wmSpaceWeather/Makefile.orig 2008-01-28 02:45:07.000000000 +0100
++++ wmSpaceWeather/Makefile 2008-01-28 02:46:04.000000000 +0100
+@@ -1,8 +1,8 @@
+-CC = gcc
+-CFLAGS = -O2 -Wall
+-INCDIR = -I/usr/X11R6/include/X11
+-DESTDIR= /usr/X11R6
+-LIBDIR = -L/usr/X11R6/lib
++CC ?= gcc
++CFLAGS += -Wall
++INCDIR = -I/usr/include/X11
++PREFIX = /usr
++LIBDIR ?= /usr/lib
+ # for linux
+ LIBS = -lXpm -lX11 -lXext
+ # for Solaris
+@@ -12,14 +12,14 @@
+
+
+ .c.o:
+- $(CC) $(COPTS) -D$(shell echo `uname -s`) -c $< -o $*.o $(INCDIR)
++ $(CC) $(CFLAGS) -D$(shell echo `uname -s`) -c $< -o $*.o $(INCDIR)
+
+
+ all: wmSpaceWeather.o wmSpaceWeather
+
+ wmSpaceWeather.o: wmSpaceWeather_master.xpm wmSpaceWeather_mask.xbm
+ wmSpaceWeather: $(OBJS)
+- $(CC) $(COPTS) $(SYSTEM) -o wmSpaceWeather $^ $(INCDIR) $(LIBDIR) $(LIBS)
++ $(CC) $(CFLAGS) -o wmSpaceWeather $^ $(INCDIR) -L$(LIBDIR) $(LDFLAGS) $(LIBS)
+
+ clean:
+ for i in $(OBJS) ; do \
+@@ -28,10 +28,10 @@
+ rm -f wmSpaceWeather
+
+ install:: wmSpaceWeather
+- install -d $(DESTDIR)/usr/bin
+- install -d $(DESTDIR)/usr/share/wmspaceweather
+- install -d $(DESTDIR)/usr/share/man/man1
+- install -m 0755 wmSpaceWeather $(DESTDIR)/usr/bin
+- install -m 0755 GetKp $(DESTDIR)/usr/share/wmspaceweather
+- install -m 0644 wmSpaceWeather.1 $(DESTDIR)/usr/share/man/man1
++ install -d $(DESTDIR)$(PREFIX)/bin
++ install -d $(DESTDIR)$(PREFIX)/share/wmspaceweather
++ install -d $(DESTDIR)$(PREFIX)/share/man/man1
++ install -m 0755 wmSpaceWeather $(DESTDIR)$(PREFIX)/bin
++ install -m 0755 GetKp $(DESTDIR)$(PREFIX)/share/wmspaceweather
++ install -m 0644 wmSpaceWeather.1 $(DESTDIR)$(PREFIX)/share/man/man1
+
+--- wmSpaceWeather/wmSpaceWeather.c.orig 2008-01-28 03:16:36.000000000 +0100
++++ wmSpaceWeather/wmSpaceWeather.c 2008-01-28 03:22:12.000000000 +0100
+@@ -663,7 +663,7 @@
+ if (GotDoubleClick1) {
+ GotFirstClick1 = 0;
+ GotDoubleClick1 = 0;
+- sprintf(Command, "sensible-browser '%s' &", URL);
++ sprintf(Command, "firefox -remote 'openURL(%s)'", URL);
+ system(Command);
+ }
+
diff --git a/x11-plugins/wmSpaceWeather/files/wmSpaceWeather-1.04_p19-getkp.patch b/x11-plugins/wmSpaceWeather/files/wmSpaceWeather-1.04_p19-getkp.patch
new file mode 100644
index 000000000000..6d6d90137feb
--- /dev/null
+++ b/x11-plugins/wmSpaceWeather/files/wmSpaceWeather-1.04_p19-getkp.patch
@@ -0,0 +1,27 @@
+--- wmSpaceWeather/GetKp.orig 2008-01-28 14:20:43.000000000 +0100
++++ wmSpaceWeather/GetKp 2008-01-28 14:22:48.000000000 +0100
+@@ -17,10 +17,10 @@
+ unlink(CUR_INDEX);
+
+
+-# $grabcmd = "cd /tmp; /usr/bin/wget -q ftp://www.sec.noaa.gov/pub/indices/DGD.txt";
++# $grabcmd = "cd /tmp; /usr/bin/wget -q http://www.swpc.noaa.gov/ftpdir/indices/DGD.txt";
+ # system "$grabcmd";
+ #
+- $grabcmd = "/usr/bin/curl -f -s -o " . DGD_FILE . " http://www.sec.noaa.gov/ftpdir/indices/DGD.txt";
++ $grabcmd = "/usr/bin/curl -f -s -o " . DGD_FILE . " http://www.swpc.noaa.gov/ftpdir/indices/DGD.txt";
+ exit 1 if (system "$grabcmd");
+
+
+@@ -69,9 +69,9 @@
+ #
+ # Add in very latest stuff
+ #
+-# $grabcmd = "cd /tmp; /usr/bin/wget -q ftp://www.sec.noaa.gov/pub/latest/curind.txt";
++# $grabcmd = "cd /tmp; /usr/bin/wget -q http://www.swpc.noaa.gov/ftpdir/latest/curind.txt";
+ # system "$grabcmd";
+- $grabcmd = "/usr/bin/curl -f -s -o " . CUR_INDEX . " http://www.sec.noaa.gov/ftpdir/latest/curind.txt";
++ $grabcmd = "/usr/bin/curl -f -s -o " . CUR_INDEX . " http://www.swpc.noaa.gov/ftpdir/latest/curind.txt";
+ exit 1 if (system "$grabcmd");
+ %lmonstr = ( "Jan", 1, "Feb", 2, "Mar", 3, "Apr", 4, "May", 5, "Jun", 6, "Jul", 7, "Aug", 8, "Sep", 9, "Oct", 10, "Nov", 11, "Dec", 12);
+