summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-plugins/wmXName
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-plugins/wmXName')
-rw-r--r--x11-plugins/wmXName/Manifest1
-rw-r--r--x11-plugins/wmXName/metadata.xml5
-rw-r--r--x11-plugins/wmXName/wmXName-0.1.ebuild47
3 files changed, 53 insertions, 0 deletions
diff --git a/x11-plugins/wmXName/Manifest b/x11-plugins/wmXName/Manifest
new file mode 100644
index 000000000000..130cac0d592f
--- /dev/null
+++ b/x11-plugins/wmXName/Manifest
@@ -0,0 +1 @@
+DIST wmXName-0.01.tgz 10757 RMD160 32eeb086c6fe86136ff5f89a48f9dba67d57e888 SHA1 fee6d5ba0a38b8862d4291fa9634aa4cbf1c3aff SHA256 3e67f87accd87d87d067e9d72bdac8d5d287e197b068e04a0e24eaf13c0aca85
diff --git a/x11-plugins/wmXName/metadata.xml b/x11-plugins/wmXName/metadata.xml
new file mode 100644
index 000000000000..b1a9efc4f2f0
--- /dev/null
+++ b/x11-plugins/wmXName/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>desktop-dock</herd>
+</pkgmetadata>
diff --git a/x11-plugins/wmXName/wmXName-0.1.ebuild b/x11-plugins/wmXName/wmXName-0.1.ebuild
new file mode 100644
index 000000000000..7f5d30261756
--- /dev/null
+++ b/x11-plugins/wmXName/wmXName-0.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+MY_PV="0.01"
+MY_P="${PN}-${MY_PV}"
+
+IUSE=""
+DESCRIPTION="dock-app showing you status of your XName hosted zones"
+SRC_URI="http://source.xname.org/${MY_P}.tgz"
+HOMEPAGE="http://source.xname.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+COMMON_DEPEND=">=x11-libs/libXpm-3.5.7
+ >=x11-libs/libX11-1.1.4
+ >=x11-libs/libXext-1.0.3"
+
+DEPEND="${COMMON_DEPEND}
+ >=sys-apps/sed-4.1.5-r1"
+
+RDEPEND="${COMMON_DEPEND}
+ >=dev-lang/perl-5.8.8-r5
+ >=www-client/lynx-2.8.6-r2"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+
+ #some magic sed to fix CFLAGS
+ sed -i "s/-O2 -Wall/$CFLAGS/" "${S}/Makefile"
+
+ #INSTALL file actually contains use instructions
+ mv "${S}/INSTALL" "${S}/README"
+}
+
+src_compile() {
+ emake SYSTEM="${LDFLAGS}" || die
+}
+
+src_install () {
+ dobin wmXName GrabXName
+ dodoc README config.sample
+}