summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-04-29 23:00:45 +0100
committerSam James <sam@gentoo.org>2021-05-04 22:17:15 +0000
commitfd66b19c5899056739734378f2ed5c75776467e4 (patch)
treee59fff028b91afafbe3a26187d98f7fccd3bb7b1 /x11-plugins/wmacpi/files
parentx11-misc/xbattbar: Respect CFLAGS (diff)
downloadgentoo-fd66b19c5899056739734378f2ed5c75776467e4.tar.gz
gentoo-fd66b19c5899056739734378f2ed5c75776467e4.tar.bz2
gentoo-fd66b19c5899056739734378f2ed5c75776467e4.zip
x11-plugins/wmacpi: Respect CFLAGS
Closes: https://bugs.gentoo.org/726270 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Closes: https://github.com/gentoo/gentoo/pull/20606 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-plugins/wmacpi/files')
-rw-r--r--x11-plugins/wmacpi/files/wmacpi-2.3-makefile.patch19
1 files changed, 10 insertions, 9 deletions
diff --git a/x11-plugins/wmacpi/files/wmacpi-2.3-makefile.patch b/x11-plugins/wmacpi/files/wmacpi-2.3-makefile.patch
index 2bf80a3190db..60629e22ad26 100644
--- a/x11-plugins/wmacpi/files/wmacpi-2.3-makefile.patch
+++ b/x11-plugins/wmacpi/files/wmacpi-2.3-makefile.patch
@@ -1,17 +1,18 @@
---- a/Makefile 2015-01-12 11:27:07.396319323 +0100
-+++ b/Makefile 2015-01-12 11:29:21.531298827 +0100
-@@ -13,8 +13,8 @@
+--- a/Makefile
++++ b/Makefile
+@@ -12,9 +12,8 @@ BUILD_CLI = 1
+ # debugging options (don't bother with these)
#OPT = -pg -g
- CC := gcc
+-CC := gcc
-CFLAGS += $(OPT) -Wall -W -g -ansi
-LDFLAGS += $(OPT) -lX11 -ldockapp
-+CFLAGS := -Wall -W -g -ansi
-+LIBS := -lX11 -ldockapp
++CFLAGS ?= -Wall -W -g -ansi
++LIBS += -lX11 -ldockapp
WMSRC := wmacpi.c libacpi.c
HEADERS := libacpi.h wmacpi.h
-@@ -26,7 +26,7 @@
+@@ -26,7 +25,7 @@ targets += wmacpi-cli
doc_targets += wmacpi-cli.1
endif
@@ -20,7 +21,7 @@
all: $(targets)
-@@ -37,7 +37,7 @@
+@@ -37,7 +36,7 @@ WMOBJ := $(patsubst %.c,%.o,$(filter %.c,$(WMSRC)))
-include $(WMOBJ:.o=.d)
wmacpi: $(WMOBJ)
@@ -29,7 +30,7 @@
# for the Debian package, we want to make building the command line tools
# optional. So, we hide all the necessary stuff here . . .
-@@ -47,13 +47,13 @@
+@@ -47,13 +46,13 @@ CLOBJ := $(patsubst %.c,%.o,$(filter %.c,$(CLSRC)))
-include $(CLOBJ:.o=.d)
wmacpi-cli: $(CLOBJ)