summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2020-06-15 17:36:10 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2020-06-15 17:41:49 +0200
commite2970576097f155e2b102aa143e8ac6475a3b246 (patch)
treeaa82688f93f57db57761a56aa10507b5bbb61f77 /x11-plugins/wmacpi/wmacpi-2.4.ebuild
parentapp-text/djvu: ppc stable wrt bug #536720 (diff)
downloadgentoo-e2970576097f155e2b102aa143e8ac6475a3b246.tar.gz
gentoo-e2970576097f155e2b102aa143e8ac6475a3b246.tar.bz2
gentoo-e2970576097f155e2b102aa143e8ac6475a3b246.zip
x11-plugins/wmacpi: 2.4 bump
Package-Manager: Portage-2.3.101, Repoman-2.3.22 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'x11-plugins/wmacpi/wmacpi-2.4.ebuild')
-rw-r--r--x11-plugins/wmacpi/wmacpi-2.4.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/x11-plugins/wmacpi/wmacpi-2.4.ebuild b/x11-plugins/wmacpi/wmacpi-2.4.ebuild
new file mode 100644
index 000000000000..b2ad3b89acca
--- /dev/null
+++ b/x11-plugins/wmacpi/wmacpi-2.4.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DESCRIPTION="DockApp ACPI status monitor for laptops"
+HOMEPAGE="https://www.dockapps.net/wmacpi"
+SRC_URI="https://www.dockapps.net/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 -ppc -sparc ~x86"
+
+DEPEND=">=x11-libs/libdockapp-0.7:=
+ x11-libs/libX11"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-makefile.patch
+ )
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}