summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2022-06-10 23:49:52 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2022-06-10 23:52:03 +0200
commit1c040cb550fa6ab596ec2297f47113d7a4fd90a4 (patch)
treeb6503ac78bfbbf2a13afc926ba8ba322941c454d /x11-plugins/wmbattery
parentwww-apps/element: add 1.10.14 (diff)
downloadgentoo-1c040cb550fa6ab596ec2297f47113d7a4fd90a4.tar.gz
gentoo-1c040cb550fa6ab596ec2297f47113d7a4fd90a4.tar.bz2
gentoo-1c040cb550fa6ab596ec2297f47113d7a4fd90a4.zip
x11-plugins/wmbattery: add 2.56
Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'x11-plugins/wmbattery')
-rw-r--r--x11-plugins/wmbattery/Manifest1
-rw-r--r--x11-plugins/wmbattery/wmbattery-2.56.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/x11-plugins/wmbattery/Manifest b/x11-plugins/wmbattery/Manifest
index 0b9532910b5b..68e10adb9c26 100644
--- a/x11-plugins/wmbattery/Manifest
+++ b/x11-plugins/wmbattery/Manifest
@@ -1 +1,2 @@
DIST wmbattery-2.54.tar.gz 87925 BLAKE2B 692549909d52096ecf7997de5122f07d9fd59b3e2d99c1421b871671a9e43f2bbdb9742e89f835a58114238509b8f8b03fd0619da4a66d8e43b6b787d4e5f6a9 SHA512 58c901ed85d3ea7e0c750bb968c3250706ed693162fe4684d75683a3897df7ff02ee4afbe12a5d26b1f1b632d4c6f9902713a632e6784173ea49bad312fd30aa
+DIST wmbattery-2.56.tar.gz 120578 BLAKE2B 992b3f2964b1ca06aabcc1727a972dcc3e7fbc294b2265c9d0435b3bb7d0c425cded78d4057d7d33ac6b3e70322d5b4b3c0cf4ce8142fb6b3222e85100937eb3 SHA512 834dd4b8b5f880c31c0c1c95c5f9580e8cc795ae8f5c56cf94957bd8d7383d4b3c0903063430a329533ae8b5eff8eed1a464cdcf3ad67bc9f6ef3c35cc9d5662
diff --git a/x11-plugins/wmbattery/wmbattery-2.56.ebuild b/x11-plugins/wmbattery/wmbattery-2.56.ebuild
new file mode 100644
index 000000000000..aef01b77a878
--- /dev/null
+++ b/x11-plugins/wmbattery/wmbattery-2.56.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="A dockable app to report APM, ACPI, or SPIC battery status"
+HOMEPAGE="https://www.dockapps.net/wmbattery"
+SRC_URI="https://www.dockapps.net/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc -sparc ~x86"
+IUSE="apm +upower"
+
+RDEPEND="apm? ( sys-apps/apmd )
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm
+ upower? ( >=sys-power/upower-0.9.23 )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( ChangeLog README TODO )
+
+src_configure() {
+ econf --disable-hal $(use_enable upower)
+}