summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2018-07-22 12:48:35 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2018-07-26 22:28:37 +0200
commit57cdaa39ecbff31b9ac959e65a12536edf565247 (patch)
tree6e812b025eb1d295e941ff55925afd3dae76d5bd /x11-plugins/wmcms/wmcms-0.3.5-r3.ebuild
parentx11-plugins/wmcms: use HTTPs (diff)
downloadgentoo-57cdaa39ecbff31b9ac959e65a12536edf565247.tar.gz
gentoo-57cdaa39ecbff31b9ac959e65a12536edf565247.tar.bz2
gentoo-57cdaa39ecbff31b9ac959e65a12536edf565247.zip
x11-plugins/wmcms: add EAPI7 ebuild
Diffstat (limited to 'x11-plugins/wmcms/wmcms-0.3.5-r3.ebuild')
-rw-r--r--x11-plugins/wmcms/wmcms-0.3.5-r3.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/x11-plugins/wmcms/wmcms-0.3.5-r3.ebuild b/x11-plugins/wmcms/wmcms-0.3.5-r3.ebuild
new file mode 100644
index 000000000000..3c00c746459e
--- /dev/null
+++ b/x11-plugins/wmcms/wmcms-0.3.5-r3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="WindowMaker CPU and Memory Usage Monitor Dock App"
+HOMEPAGE="https://www.geocities.ws/neofpo/wmcms.html"
+SRC_URI="https://www.geocities.ws/neofpo/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND=">=x11-libs/libdockapp-0.7:="
+
+src_prepare() {
+ default
+ eapply "${FILESDIR}"/wmcms-0.3.5-s4t4n.patch
+
+ # Respect LDFLAGS, see bug #335031
+ sed -e 's/ -o wmcms/ ${LDFLAGS} -o wmcms/' -i Makefile || die
+
+ sed -e 's#<dockapp.h>#<libdockapp/dockapp.h>#' -i *.c || die
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dobin wmcms
+}