summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2018-07-23 20:36:23 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2018-08-02 22:17:56 +0200
commitf636e22858e846912c7a01ae9aba0a0bc9895b81 (patch)
tree02a07d418f02647bb305ac97158092070cb6521a /x11-plugins/wmping/wmping-0.2.1-r1.ebuild
parentx11-plugins/wmpeople: EAPI7, improve ebuild (diff)
downloadgentoo-f636e22858e846912c7a01ae9aba0a0bc9895b81.tar.gz
gentoo-f636e22858e846912c7a01ae9aba0a0bc9895b81.tar.bz2
gentoo-f636e22858e846912c7a01ae9aba0a0bc9895b81.zip
x11-plugins/wmping: EAPI7, improve ebuild
Diffstat (limited to 'x11-plugins/wmping/wmping-0.2.1-r1.ebuild')
-rw-r--r--x11-plugins/wmping/wmping-0.2.1-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/x11-plugins/wmping/wmping-0.2.1-r1.ebuild b/x11-plugins/wmping/wmping-0.2.1-r1.ebuild
new file mode 100644
index 000000000000..ab211f81e7b3
--- /dev/null
+++ b/x11-plugins/wmping/wmping-0.2.1-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="a simple host status monitoring dockapp"
+HOMEPAGE="https://sourceforge.net/projects/wmping"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+suid"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto
+ x11-libs/libICE
+ x11-libs/libXt"
+
+PATCHES=( "${FILESDIR}"/${P}-format-security.patch )
+
+DOCS=( AUTHORS CHANGES README )
+
+src_install() {
+ if use suid; then
+ default
+ else
+ dosbin ${PN}
+ einstalldocs
+ fi
+ doman ${PN}.1
+}
+
+pkg_postinst() {
+ use suid || ewarn "warning, ${PN} needs to be executed as root."
+}