summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-plugins/wmtime/wmtime-1.0_beta2_p9.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-plugins/wmtime/wmtime-1.0_beta2_p9.ebuild')
-rw-r--r--x11-plugins/wmtime/wmtime-1.0_beta2_p9.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/x11-plugins/wmtime/wmtime-1.0_beta2_p9.ebuild b/x11-plugins/wmtime/wmtime-1.0_beta2_p9.ebuild
new file mode 100644
index 000000000000..5258825dab53
--- /dev/null
+++ b/x11-plugins/wmtime/wmtime-1.0_beta2_p9.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils versionator
+
+MY_PV="$(get_version_component_range 1-2)"
+MY_PL="$(get_version_component_range 3)"
+MY_PL="${MY_PL/beta/b}"
+MY_PV="${MY_PV}${MY_PL}"
+MY_PL="$(get_version_component_range 4)"
+MY_PL="${MY_PL/p/}"
+
+IUSE=""
+
+DESCRIPTION="applet which displays the date and time in a dockable tile"
+SRC_URI="http://ftp.debian.org/debian/pool/main/w/wmtime/wmtime_${MY_PV}.orig.tar.gz
+ http://ftp.debian.org/debian/pool/main/w/wmtime/wmtime_${MY_PV}-${MY_PL}.diff.gz"
+HOMEPAGE="http://packages.qa.debian.org/w/wmtime.html"
+
+SLOT="0"
+KEYWORDS="~amd64 x86"
+LICENSE="GPL-2"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-proto/xproto
+ x11-proto/xextproto
+ >=sys-apps/sed-4"
+
+S="${WORKDIR}/${PN}-${MY_PV}.orig/${PN}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${WORKDIR}"
+
+ # apply debian patch
+ epatch "${PN}_${MY_PV}-${MY_PL}.diff"
+
+ # honour Gentoo LDFLAGS, bug #335799
+ sed -i "s/-o wmtime/\$(LDFLAGS) -o wmtime/" "${S}/Makefile"
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" || die "emake failed"
+}
+
+src_install () {
+ dobin wmtime
+ doman wmtime.1
+
+ cd ..
+ dodoc BUGS CHANGES HINTS README TODO
+
+ # install sample config file, too
+ dodoc debian/wmtimerc
+}