summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2020-03-29 13:17:12 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2020-03-29 13:35:24 +0200
commit218ed79926574f50c582795dafb2d6dd4d29465d (patch)
tree3dccb2bc2da2e566c96321f4b809bc95241d2d3b /x11-plugins
parentx11-plugins/wmacpi: fix build with -fno-common (diff)
downloadgentoo-218ed79926574f50c582795dafb2d6dd4d29465d.tar.gz
gentoo-218ed79926574f50c582795dafb2d6dd4d29465d.tar.bz2
gentoo-218ed79926574f50c582795dafb2d6dd4d29465d.zip
x11-plugins/wmweather: fix build with -fno-common
Closes: https://bugs.gentoo.org/714802 Package-Manager: Portage-2.3.96, Repoman-2.3.22 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmweather/files/wmweather-2.4.7-fno-common.patch23
-rw-r--r--x11-plugins/wmweather/wmweather-2.4.7.ebuild9
2 files changed, 31 insertions, 1 deletions
diff --git a/x11-plugins/wmweather/files/wmweather-2.4.7-fno-common.patch b/x11-plugins/wmweather/files/wmweather-2.4.7-fno-common.patch
new file mode 100644
index 000000000000..5db5fbcc2e34
--- /dev/null
+++ b/x11-plugins/wmweather/files/wmweather-2.4.7-fno-common.patch
@@ -0,0 +1,23 @@
+diff -Naur wmweather-2.4.7.orig/src/wmgeneral.h wmweather-2.4.7/src/wmgeneral.h
+--- wmweather-2.4.7.orig/src/wmgeneral.h 2019-02-13 20:54:48.000000000 +0100
++++ wmweather-2.4.7/src/wmgeneral.h 2020-03-29 13:14:19.373976239 +0200
+@@ -36,7 +36,7 @@
+ /* Global variable */
+ /*******************/
+
+-Display *display;
++extern Display *display;
+
+ /***********************/
+ /* Function Prototypes */
+diff -Naur wmweather-2.4.7.orig/src/wmweather.c wmweather-2.4.7/src/wmweather.c
+--- wmweather-2.4.7.orig/src/wmweather.c 2019-02-13 20:54:49.000000000 +0100
++++ wmweather-2.4.7/src/wmweather.c 2020-03-29 13:14:57.254963956 +0200
+@@ -56,6 +56,7 @@
+ static void update(int);
+ static size_t curl_callback(void*, size_t, size_t, void*);
+
++Display *display;
+ CURL
+ *curl = NULL;
+ static struct memory
diff --git a/x11-plugins/wmweather/wmweather-2.4.7.ebuild b/x11-plugins/wmweather/wmweather-2.4.7.ebuild
index 2109007a6f6d..174e4977f14a 100644
--- a/x11-plugins/wmweather/wmweather-2.4.7.ebuild
+++ b/x11-plugins/wmweather/wmweather-2.4.7.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -27,3 +27,10 @@ DOCS=(
"${WORKDIR}"/${P}/CHANGES
"${WORKDIR}"/${P}/README
)
+
+src_prepare() {
+ default
+
+ pushd "${WORKDIR}"/${P} || die
+ eapply "${FILESDIR}"/${P}-fno-common.patch
+}