summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2019-07-30 22:46:36 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2019-07-30 22:47:04 +0200
commit32c269aca1e75d6a6bcc3909b2a5ad184849532b (patch)
tree046230764529af3fbf6e5636338a296c90a62185 /x11-plugins
parentx11-plugins/wmamixer: add missing alsa-lib dependency (diff)
downloadgentoo-32c269aca1e75d6a6bcc3909b2a5ad184849532b.tar.gz
gentoo-32c269aca1e75d6a6bcc3909b2a5ad184849532b.tar.bz2
gentoo-32c269aca1e75d6a6bcc3909b2a5ad184849532b.zip
x11-plugins/wmfire: drop broken inlining
Closes: https://bugs.gentoo.org/686136 Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmfire/files/wmfire-1.2.4-inline_c99.patch21
-rw-r--r--x11-plugins/wmfire/wmfire-1.2.4-r3.ebuild3
2 files changed, 23 insertions, 1 deletions
diff --git a/x11-plugins/wmfire/files/wmfire-1.2.4-inline_c99.patch b/x11-plugins/wmfire/files/wmfire-1.2.4-inline_c99.patch
new file mode 100644
index 000000000000..34846bf86bdc
--- /dev/null
+++ b/x11-plugins/wmfire/files/wmfire-1.2.4-inline_c99.patch
@@ -0,0 +1,21 @@
+diff -Naur wmfire-1.2.4.orig/src/wmfire.c wmfire-1.2.4/src/wmfire.c
+--- wmfire-1.2.4.orig/src/wmfire.c 2005-12-04 11:39:16.000000000 +0100
++++ wmfire-1.2.4/src/wmfire.c 2019-07-30 22:43:03.306268675 +0200
+@@ -108,7 +108,7 @@
+ void change_flame(int);
+ GdkCursor *setup_cursor();
+ void burn_spot(int, int, int);
+-inline void draw_fire(unsigned int);
++void draw_fire(unsigned int);
+ static void make_wmfire_dockapp();
+ void read_config(int, char **);
+ void do_help(void);
+@@ -470,7 +470,7 @@
+ /* Draw fire */
+ /******************************************/
+
+-inline void
++void
+ draw_fire(unsigned int load)
+ {
+ int x, y, i, j;
diff --git a/x11-plugins/wmfire/wmfire-1.2.4-r3.ebuild b/x11-plugins/wmfire/wmfire-1.2.4-r3.ebuild
index dbf51f0404f5..eb4a64478ef2 100644
--- a/x11-plugins/wmfire/wmfire-1.2.4-r3.ebuild
+++ b/x11-plugins/wmfire/wmfire-1.2.4-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -30,6 +30,7 @@ src_prepare() {
eapply "${FILESDIR}"/${PN}-1.2.3-stringh.patch
eapply "${FILESDIR}"/${P}-no_display.patch
eapply "${FILESDIR}"/${P}-lastprocessor_SMP.patch
+ eapply "${FILESDIR}"/${P}-inline_c99.patch
eautoreconf
}