summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2020-02-24 22:04:08 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2020-02-24 22:04:17 +0100
commit6c791c6916797f02353697a56acf4d2f8131c4f9 (patch)
tree865a48f0b7b2831bb75650a89d15281ef43df211 /x11-plugins
parentx11-plugins/wmpop3lb: replace ":" as sed delimiter (diff)
downloadgentoo-6c791c6916797f02353697a56acf4d2f8131c4f9.tar.gz
gentoo-6c791c6916797f02353697a56acf4d2f8131c4f9.tar.bz2
gentoo-6c791c6916797f02353697a56acf4d2f8131c4f9.zip
x11-plugins/wmdots: replace ":" as sed delimiter
Closes: https://bugs.gentoo.org/710714 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmdots/wmdots-0.2_beta-r1.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/x11-plugins/wmdots/wmdots-0.2_beta-r1.ebuild b/x11-plugins/wmdots/wmdots-0.2_beta-r1.ebuild
index e38905e13292..5aaba6401e1c 100644
--- a/x11-plugins/wmdots/wmdots-0.2_beta-r1.ebuild
+++ b/x11-plugins/wmdots/wmdots-0.2_beta-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -23,14 +23,14 @@ S="${WORKDIR}/${PN}"
src_prepare() {
default
eapply "${FILESDIR}"/${P}-stringh.patch
- sed -e "s:cc:$(tc-getCC):g" \
- -e "s:-g -O2:${CFLAGS}:g" -i Makefile || die
+ sed -e "s|cc|$(tc-getCC)|g" \
+ -e "s|-g -O2|${CFLAGS}|g" -i Makefile || die
#Fix compilation target
- sed -e "s:wmifs:wmdots:" -i Makefile || die
+ sed -e "s|wmifs|wmdots|" -i Makefile || die
#Honour Gentoo LDFLAGS, see bug #336982
- sed -e "s:-o wmdots:\$(LDFLAGS) -o wmdots:" -i Makefile || die
+ sed -e "s|-o wmdots|\$(LDFLAGS) -o wmdots|" -i Makefile || die
}
src_compile() {