summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-20 02:29:42 +0100
committerSam James <sam@gentoo.org>2021-04-20 02:42:23 +0100
commit6c80cd6b64de6fa402412eae6b1dd0b8f51cc135 (patch)
treed7a96aad8080377cf1906d70b6d502f437f35949 /x11-plugins
parentnet-dns/djbdns: new revision with $AR and $RANLIB support. (diff)
downloadgentoo-6c80cd6b64de6fa402412eae6b1dd0b8f51cc135.tar.gz
gentoo-6c80cd6b64de6fa402412eae6b1dd0b8f51cc135.tar.bz2
gentoo-6c80cd6b64de6fa402412eae6b1dd0b8f51cc135.zip
x11-plugins/pidgin-xmpp-receipts: port to EAPI 7
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/pidgin-xmpp-receipts/pidgin-xmpp-receipts-0.8.ebuild11
1 files changed, 5 insertions, 6 deletions
diff --git a/x11-plugins/pidgin-xmpp-receipts/pidgin-xmpp-receipts-0.8.ebuild b/x11-plugins/pidgin-xmpp-receipts/pidgin-xmpp-receipts-0.8.ebuild
index f16b5e0b5d7c..c62d3d1c907e 100644
--- a/x11-plugins/pidgin-xmpp-receipts/pidgin-xmpp-receipts-0.8.ebuild
+++ b/x11-plugins/pidgin-xmpp-receipts/pidgin-xmpp-receipts-0.8.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
inherit vcs-snapshot toolchain-funcs
@@ -12,20 +12,19 @@ SRC_URI="https://github.com/noonien-d/pidgin-xmpp-receipts/archive/release_${PV}
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="amd64"
-IUSE=""
RDEPEND="net-im/pidgin[gtk]"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
src_compile() {
- GTK_PIDGIN_INCLUDES=$($(tc-getPKG_CONFIG) --cflags gtk+-2.0 pidgin)
+ GTK_PIDGIN_INCLUDES="$($(tc-getPKG_CONFIG) --cflags gtk+-2.0 pidgin)"
$(tc-getCC) ${LDFLAGS} -shared ${CFLAGS} -fpic ${GTK_PIDGIN_INCLUDES} -o ${PN/pidgin-/}.so ${PN/pidgin-/}.c || die
}
src_install() {
PLUGIN_DIR_PIDGIN=$($(tc-getPKG_CONFIG) --variable=plugindir pidgin)
- dodir "${PLUGIN_DIR_PIDGIN}"
+
insinto "${PLUGIN_DIR_PIDGIN}"
doins ${PN/pidgin-/}.so
}